Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25
  1. #11
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    San Antonio, Texas
    Posts
    16,075
    +1
    28
    Quote Originally Posted by RDH View Post
    this definitly needs to be a sticky...
    done.


  2. #12
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,584
    +1
    2
    where'd you buy that welnut?

    what section was it in? plumbing?

  3. #13

    Join Date
    Sep 2006
    Location
    Holland Ohio
    Posts
    119

    nutz

    Lowes should have them ,Home Depot, Ace hardware they`ll be in the hardware fastener isle , black with a brass thread insert

  4. #14
    Greenhulk Grasshopah (DRC) HallPass's Avatar
    Join Date
    Jun 2007
    Location
    Kansas
    Posts
    5,584
    +1
    2
    Quote Originally Posted by ltd-187 View Post
    Lowes should have them ,Home Depot, Ace hardware they`ll be in the hardware fastener isle , black with a brass thread insert
    YUP i got some

  5. #15
    I've installed the gas powervalves successfully on my EFI 1390 but when I start the ski, the warning light and buzzer go off. The code is 64 for malfunctioning PV motor. Well the PV motor isn't in the ski, so no wonder..... But my question is, am I stupid and shouldn't have ever taken the PV motor out? Or is there something I'm missing?

    Do you guys really deal with that buzzer going off everytime you start the ski?

  6. #16
    Moderator OsideBill's Avatar
    Join Date
    Mar 2006
    Location
    United States
    Posts
    11,874
    +1
    38
    this must be unique to the 1300's the 1200's don't do this.

  7. #17
    The electronics are from an 04 13r......

    What do you guys think? Hook up the PV motor and just disconnect the cables? Or do you think I could find a burned up PV motor and then use a resistor of some sort and the plug to fool it to thinking that it's there? Thoughts?

  8. #18

    Join Date
    Jun 2010
    Location
    Cayman Islands
    Posts
    34

    springs

    are the springs for these necessary? mines didnt come with any

  9. #19
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,952
    +1
    483
    Quote Originally Posted by newmechanic View Post
    are the springs for these necessary? mines didnt come with any
    must have the top spring, or they will pop open when you give it throttle and bog

  10. #20

    Join Date
    Jun 2010
    Location
    Cayman Islands
    Posts
    34

    WFO

    thanks, is there anywhere that i can get the springs seperately? instead of buying the whole kit

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gp1200r riva gas power valve review
    By Mvpxspeedy in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-12-2012, 07:38 PM
  2. WTB Riva gas power valve gp1200r
    By Vagaondracing103 in forum Yamaha Classifieds
    Replies: 0
    Last Post: 03-23-2012, 04:29 PM
  3. WTB Riva gas power valves for 2001 gpr1200
    By waverider1200 in forum Yamaha Classifieds
    Replies: 3
    Last Post: 07-21-2011, 06:55 AM
  4. WTB 1 Riva Gas Power Valve ( Valve Only)
    By tokeytokertin in forum Yamaha Classifieds
    Replies: 0
    Last Post: 04-21-2011, 09:25 AM
  5. Riva gas Power Valve Question 2001 gpr 1200
    By patrick webb in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-19-2009, 12:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •