Results 1 to 3 of 3

Thread: No Spark

  1. #1

    Join Date
    Feb 2008
    Posts
    15

    No Spark

    04 Freedom has no spark. Press and hold bilge pump switch while cranking it has good spark. What now,bought as basket case, rebuilt and rewired, possible wrong connection?


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    46,762
    +1
    2,739
    Download the 2003 Service Manual, check the wiring against the diagrams.

    If you hold the bilge pump button, will it actually start and then keep running?

  3. #3

    Join Date
    Feb 2008
    Posts
    15
    Yes it starts,release both buttons and it stays running.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No spark and water temp alarm
    By ybnormal in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-02-2009, 11:02 AM
  2. Engine cranks - but no spark
    By croskel in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 07-12-2006, 01:36 PM
  3. No Spark Help
    By mt375hp in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-27-2006, 04:07 AM
  4. No Spark ?
    By OsideBill in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-07-2006, 03:27 AM
  5. Uncovered my GTX today, has no spark.
    By ccassone in forum Sea Doo Open Discussion
    Replies: 33
    Last Post: 03-27-2006, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •