Page 6 of 6 FirstFirst ... 456
Results 51 to 58 of 58
  1. #51
    I am new to a forum posting. I have a 2003 Seadoo GTX Supercharged that has only about 40 hrs on it. It is blowing out oil into the hull at high RPM. It will loose 2-3 qts in a few minutes at top RPM. Lower RPM the oil will last longer. It is not burning oil but leaking it into the hold area of the hull.
    Any Ideas on what it could be?

    Thank u


  2. #52
    What, you dont have to pull the drive shaft to pull the motor??? 05 GTX LTD super charged... Im down to the block, but i'm looking for that clip, and dont see anything.

  3. #53
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,796
    +1
    81
    Quote Originally Posted by DGSAUTOTECH View Post
    What, you dont have to pull the drive shaft to pull the motor??? 05 GTX LTD super charged... Im down to the block, but i'm looking for that clip, and dont see anything.
    you need to pull back the carbon seal and top hat, the circlip is under the top hat. make sure pump is in place. It can be fairly difficult. you can place a 10mm socket in the spline area in the prop and that will push the driveshaft forward enough to pull the clip out

  4. #54
    removed the engine, not removing the pump or unscrewing the mounts. just removed the top bolt. Would i be okay placing it back on its spot and assuming it will line up back to its original place? any tricks?
    Last edited by MrIgor; 11-21-2012 at 05:53 PM.

  5. #55

    Engine-to-driveshaft alignment

    Quote Originally Posted by Franko View Post
    I was going to post this very same tip. But a better tip is get an impact wrench and air compressor. With the tight ass head bolts and bolts and plugs under the engine, it will save you some serious elbow grease.

    If you reinstall the engine using the same shimming that was originally on the motor mounts, is it very important to do a shaft alignment with the special alignment tool?

  6. #56
    scottcls55's Avatar
    Join Date
    Mar 2009
    Location
    KY Go WKU!!
    Posts
    21
    Need some help please..
    Bought a 10 rxt-x at auction low compression pulling motor. Got everything off like this thread says but I think the 10 driveshaft is different cant find a circlip. Moved the front bearing back and cant find it there the moved the carbon ring back didn't see one there.
    Pulled forward on engine and whole driveshaft comes forward instead of releasing.
    Is there a circlip to release a 10 driveshaft ? Or do you think my shaft is corroded into the coupler and not releasing?
    Thanks for help!

  7. #57
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,082
    +1
    791
    scot

    Read this and down load pdf's http://www.greenhulk.net/forums/showthread.php?t=137116

    Get a shop manual here: www.brpmanuals.com

    Get the 2011 Shop Manual because the 2010 is missing info and the 2011 is identical to the 2010 T-X.

    The 2010-11 drive shafts are bastard designs ( no c-clip) and need to be replaced with 2012-2015 shafts and components due to poor metallurgy and spline failures. Use the search function and you will find many many 2010-11 drive shaft failures.

    If you can't get the screw on floating ring off, simply cut the drive shaft in half as you do NOT want to use it anyway!

  8. #58
    Quote Originally Posted by 05Limited View Post
    Josh... I'll get some better pics tomorrow but it is really quite easy. I use three of the spacers that come with the R&D wedge but any large, thick nuts will work. This is a Kragen's stand.

    Jeff
    What size and legth bolts are needed to mount engine to the stand?

Page 6 of 6 FirstFirst ... 456

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine removal and installation links
    By Smitty in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 01-04-2013, 08:28 PM
  2. Replies: 4
    Last Post: 05-07-2011, 11:28 PM
  3. Detailed Jet pump removal, rebuild, and assembly?
    By joeboatertx in forum Yamaha How To & FAQs
    Replies: 10
    Last Post: 10-15-2010, 11:20 PM
  4. 1999 Genesis engine rebuild (need some tips and help)
    By markdgenesis in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-17-2009, 04:50 PM
  5. Would I be crazy if I tried to rebuild and install my motor by myself???
    By espritonsevas in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 04-13-2009, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •