Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 52
  1. #21

    Join Date
    May 2008
    Location
    Savannah, GA
    Posts
    452
    Quote Originally Posted by addicted View Post
    Heat the pump hub woth a torch. the aluminum will expand and you should be able to tap or just slide the shaft and bearings out. Wear heavy leather gloves and do it outside because the grease will smoke.
    I will try that again. I guess that I did not heat it enough. By any chance do you have the spacer that goes between the impeller and the seals? Mine is missing.


  2. #22
    cheatin' piston popper addicted's Avatar
    Join Date
    Jul 2006
    Location
    north jersey
    Posts
    6,188
    +1
    174
    Mapp gas torch is a mechanics best friend Sorry, no spacers here.

  3. #23

    Join Date
    May 2008
    Location
    Savannah, GA
    Posts
    452
    Mike, I was able to remove the shaft from the pump by REALLY heating it. Yeah the grease does stink BTW! I am currently CHILLIN a driveshaft in the freezer as I type. I will keep posted

  4. #24
    Brewster's Avatar
    Join Date
    Aug 2007
    Location
    Cape Cod, Ma.
    Posts
    317
    Just reading this for the first time, awesome stuff. That is really some smart thinking.

  5. #25

    Join Date
    May 2008
    Location
    Savannah, GA
    Posts
    452
    Well my silly arse is fixin to put it to the test shortly...gotta get a beer first though

  6. #26

    Join Date
    May 2008
    Location
    Savannah, GA
    Posts
    452
    Quote Originally Posted by roost5o View Post
    Well my silly arse is fixin to put it to the test shortly...gotta get a beer first though
    Weeeellllll I got that beer and a few others. Folks this WORKS!!!!! I just installed the bearings on the shaft and then into the housing...AWESOME!!!
    Dayumm this forum ROCKS!!!!!

  7. #27
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,532
    +1
    211
    Quote Originally Posted by roost5o View Post
    I will try that again. I guess that I did not heat it enough. By any chance do you have the spacer that goes between the impeller and the seals? Mine is missing.
    mine was also missing although i did not notice any problems
    or it fell out after i took the last impellor off (although i don't think it did )
    new impellor seemed to be in the same place as the last one ,
    and this one with the spacer still seams to be in the same place
    sort of glad i decided to replace the bearings and seals, i had alredy put on a new impellor and refited the pump but i was not 100% that the bearings were still good so ordered new ones and changed them to be sure ,the old ones seem to be ok but beter to be safe than sorry

    kev

  8. #28
    On my pump (144mm raider) I'm supposed to put the driveshaft and first bearing into the pump housing and then fill the space to the second bearing with marine grease before putting the second bearing on. The seals are supposed to go in first, but could go on after everything cools down.
    With this method both bearings would already be on the driveshaft so is there an easy way of adding the grease? I was thinking something like a turkey baster filled with warm grease and 1/4 inch before the last bearing slides in pump it all in. But would a 350 degree pump housing and a frozen driveshaft affect the grease?

  9. #29
    Team RTYD burton9010's Avatar
    Join Date
    Apr 2008
    Location
    Sacramento CA
    Posts
    290
    I am thinking about doing the same thing to my pump. I have not taken mine apart yet so I am not sure how it looks but is there a way to drill and tap a grease fitting that you could just pump full when you get it back together?

  10. #30
    I've seen the rear cone modded with a nipple , but I usually do it the old fashioned way ' I also load the cavity between the bearings with grease before I drop it into the hot housing

Page 3 of 6 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pump bearings removal tips
    By CJ's gpr in forum Polaris How To & FAQs
    Replies: 18
    Last Post: 01-27-2014, 03:29 PM
  2. 15F Pump Bearing Install Concerns/Questions
    By kawa900stx in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-23-2013, 08:33 AM
  3. Supercharger needle bearing install tips?
    By Tripower in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-27-2012, 09:31 AM
  4. Sealing pump and installing impeller this weekend. Any tips?
    By yamadood in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 03-11-2011, 07:37 PM
  5. Q...Installing new pump bearings...Q:
    By SideFX in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-22-2010, 02:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •