Results 1 to 7 of 7
  1. #1

    Injector /ECU Problem

    I have a question that is beyond me and was looking for some help. I have a 2021 GP1800 SVHO, the year I bought it I went with a Riva stage 2 and the ski ran great for 100 hours the first year. Over the winter I decided to go stage 3. Installed a 17 lb wheel, shaft upgrade and injectors. I couldnt get the Riva injectors and went with ones I bought from Deans. Ski ran very good with no issues for about an hour. It died and I brought it home and tore it apart, I found that the 3rd cyl from the front was wiped out and piston was sideways in the bore. I thought it was an injector that took a dump. I sent the injectors out to be checked and tested. He dynamic checked them, put new seals on them and said they were good. I fixed the engine and reinstalled it while putting the injectors in the same cyls as before. While running it I unplugged each injector and they all were working. Took the ski out and after about an hour it died. I brought it home and the exact thing happened again. At this point it has to be either the injector (I bought new Riva 100lb injectors) or the ECU. Has anyone else had this problem? Thoughts? Sorry the post was so long. Thanks in advance.

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canadia
    Posts
    47,491
    +1
    2,854
    Quote Originally Posted by cioccoj View Post
    … At this point it has to be either the injector (I bought new Riva 100lb injectors) or the ECU. …
    Were you able to deduce anything from the damaged pistons, such as signs of detonation or lean burn damage precipitating the piston mechanical failure?

    Which ECU tune(s) are you using?

    After the injector service company said all the tested fuel injectors were good, where else did you look for possible failure cause?

    Sometimes the injector wire harness connectors can weaken at the wire crimps. Have you taken the pins out and inspected for possible issues?

    Does your engine have any ECU/tune monitoring such as AFR sensor?

  3. #3
    Im not really sure what to deduce. Detonation, both skirts are gone? Im using a Riva tune stage 3 9500. With the ski running I did check all the injector harnesses and unplugged each one and did see a noticable difference telling me their all working. The ski ran great with no problems until I did the wheel and injectors, thats why I keep going back to the injectors. When he tested them it was dynamic which is just at full open. Thanks
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	316743436_1315906102535869_7920158810661718779_n.jpg 
Views:	136 
Size:	68.4 KB 
ID:	488878  

  4. #4
    And I do not have an AFR guage. But again, same injector in same cyl.

  5. #5
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,601
    +1
    194
    Air fuel gauge is a must for this kind of Set up..... your blindly adding boost & rpms to the machine...

    middle 2 jugs tend to run leaner then liters just from intake placement. Tuners say they compensate. Harness failer on injector? Injector?, or just lean tune. How hard were you pushing it.

  6. #6
    Im going to add an AFR guage this time for sure. But wouldnt you think that the Riva tune I used would be on the safer side of lean? It was the one they recommended. I was running it hard, seeing 9300, but not holding it there for really long periods of time. I did check the injector harnesses prior to running it. Im thinking bad injector, but possible bad ECU keeps creeping into my head. Have you ever seen an ECU lose the driver for just one cyl?


  7. #7
    Reaper9789's Avatar
    Join Date
    Jul 2014
    Location
    Canyon Lake, TX
    Posts
    940
    +1
    134
    First thing I did when I was having issues is buy some pigtails and get rid of the stupid injector adapters.
    It would be wort the money at this point to get the datalog setup and log some runs.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 215 engine, injector 3 flooding - ecu problem?
    By MrIgor in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-30-2019, 01:51 PM
  2. Help with ECU/Injector problem on 2007 FX Cruiser HO
    By Propilotdc in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 11-08-2015, 06:30 AM
  3. 02 gtx 4 tec ecu or injector problem
    By BocaBoyz in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-28-2014, 05:20 PM
  4. injector problem
    By fh23rxp-x in forum 4-Tec Performance
    Replies: 17
    Last Post: 11-19-2010, 07:00 AM
  5. 02 GTX DI injector problem
    By dtfly in forum 2-Stroke Performance
    Replies: 9
    Last Post: 06-17-2010, 10:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •