Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    RXTX 255 RS restricted

    hey guys,

    Have tried doing a search but cant find the answer.

    I picked up my new 2009 RXTX 255 rs yesterday with 130 hours the clock.

    The supercharger as rebuilt at 100 hours from the previous owner with receipts.

    I took it out for a ride yesterday as i was excited to get on it. filled the tank with 98 premium.
    it did have 2 bars left of old fuel from last year from the previous owner.

    When riding the ski i tried to hit the top speed which i assume would be 113km/h like my old rxpx i had about 10 years ago but it would only get upto 90km/h and 6700rpm.

    it was serviced by the previous owner last month and hasnt been ridden since. serviced included oil, oil filter and spark plugs.

    After doing some reading trying to figure it out today i went through and checked that the throttle body was opening fully, all the hoses were tight and couldn't find any splits or holes, oil level is correct right in the middle, supercharger impeller as tight as and i couldnt turn it by hand, wear ring had barely any damage but i changed it anyway, although i doubt it would be this as id assume it would still rev out and just not go any faster?

    I didnt bother pulling any of the plugs seeing as they were changed last month and the ride i did yesterday was the first its had since.

    The ski did not cough splutter or act badly at all. it accelerated fast until 85kmh then creeped slowly to 90.

    Is anyone able to recommend where to look next to figure out this issue?

    Thanks

  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    2,086
    +1
    280
    Could be a bad spark plug, as they were changed but not used.


  3. #3
    Leaking intercooler?

  4. #4
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    38,977
    +1
    3,428
    Your RPM's are very low. Look for a boost leak in your intercooler plumbing. Also, the intake manifolds are prone to splitting. this part prevents that
    http://www.4-tecperformance.com/inde...oducts_id=4035

    I would also pull your supercharger and check slip properly and shim it up if needed. It could be your supercharger clutch is slipping at high RPM.

  5. #5
    Thanks guys, Click image for larger version. 

Name:	20220927_193224.jpg 
Views:	25 
Size:	33.2 KB 
ID:	487850Click image for larger version. 

Name:	20220927_193224.jpg 
Views:	25 
Size:	33.2 KB 
ID:	487850

    I pulled the spark plugs they all look fine. I have attached a photo of them..

    I also borrowed a smoke machine off a mate and filled all hoses etc with smoke and can not see any leaks anywhere. Test exhaust boxes and manifold with it too.

    I did notice the spark plugs were very loose to undo. Not sure if this will make a difference? But they were just past hand tight. I reckon I could of undone them with just holding the extension bar without the ratchet.

    Have not checked the supercharger slip as I'm not really sure how to do that and I have run out of time tonight..

  6. #6
    Quote Originally Posted by mitch2331992 View Post
    I also borrowed a smoke machine off a mate and filled all hoses etc with smoke and can not see any leaks anywhere. Test exhaust boxes and manifold with it too.
    By leak I meant water leaking into the intercooler, not a boost leak.

  7. #7

    Join Date
    Jun 2019
    Location
    Northeastern Mass.
    Posts
    696
    +1
    74
    Quote Originally Posted by J.Harris View Post
    By leak I meant water leaking into the intercooler, not a boost leak.
    Had it happen to me

  8. #8
    Oh I see. Best way to check that is by taking a hose off the intercooler from the throttle body and running the ski correct? Seeing if any water is going into the intercooler?

  9. #9
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    1,556
    +1
    137
    Quote Originally Posted by mitch2331992 View Post
    Oh I see. Best way to check that is by taking a hose off the intercooler from the throttle body and running the ski correct? Seeing if any water is going into the intercooler?
    Best way is to remove the intercooler and pressure test it.

  10. #10
    So I took the ski out today. Got it to rev to 6840rpm and maxed out at 94km/h

    After riding my mates GTR 230 it just doesn't have the launch his does.

    The weird thing is. When the ski was put back on the trailer I revved it to clear it out and it hit rev limiter no problem on the trailer out of the water. 8000rpm. And backfired.

    Any ideas?

    I'm going to change to the plugs tomorrow morning again before o take the ski out.

    Still haven't checked supercharger slip yet. But just weird that it revs out when it's on the trailer?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts RXTX 255 Parts
    By meeper in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 08-20-2019, 08:41 AM
  2. 08 rxtx 255 impeller help
    By jdakrt in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-08-2019, 10:43 AM
  3. SOLD 05-08í rxtx 255++ $4,000
    By psycho rxp in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 05-10-2019, 06:52 PM
  4. Rxtx 255 2008
    By nephtor in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-29-2018, 03:34 PM
  5. New kit for RXTX 255
    By SideFX in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-18-2008, 02:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •