Page 5 of 11 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 102
  1. #41
    Quote Originally Posted by 1tommygunner1927 View Post
    This is the basic shape of the bracket. I'll need to take a photo of it on the engine.
    I don't understand on the first picture how did you connect the 2 brackets ....
    The connection with the bushing seems slotted and seems that is not supporting the turbo...

  2. #42
    1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,628
    +1
    2,827
    Quote Originally Posted by jetplane View Post
    I don't understand on the first picture how did you connect the 2 brackets ....
    The connection with the bushing seems slotted and seems that is not supporting the turbo...

    The long slotted part (is not fully seated in the rubber mount for the photo), the other end at the top attaches at the rear of the turbo compressor housing with one bolt.

  3. #43
    1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,628
    +1
    2,827
    Quote Originally Posted by jetplane View Post
    I have the 161 mm pump , what do you suggest as start point ? A 300 oem impeller pitch is too short ?
    Add PRV's before you pull the trigger. S3 hulls are known to pump stuff at 82-84 mph. I have no experience with 161 mm pumps.

  4. #44
    Quote Originally Posted by 1tommygunner1927 View Post
    Add PRV's before you pull the trigger. S3 hulls are known to pump stuff at 82-84 mph. I have no experience with 161 mm pumps.
    Where to get them , I am totally ignorant about them .

  5. #45
    Quote Originally Posted by 1tommygunner1927 View Post
    The long slotted part (is not fully seated in the rubber mount for the photo), the other end at the top attaches at the rear of the turbo compressor housing with one bolt.
    So if it not fully seatead is not suppprting the turbo ....

  6. #46
    Actually I am using the 300 spark plugs with 300 ignition coils and 300 head cover .What do you guys suggest for the turbo application?

  7. #47
    1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,628
    +1
    2,827
    Quote Originally Posted by jetplane View Post
    So if it not fully seatead is not suppprting the turbo ....

    I photographed it during mock up (forgot I had those pics). As installed, bracket is fully seated.


  8. #48
    1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,628
    +1
    2,827
    Quote Originally Posted by jetplane View Post
    Actually I am using the 300 spark plugs with 300 ignition coils and 300 head cover .What do you guys suggest for the turbo application?
    Perfect! One day I'll make the switch to the 300 ignition.

  9. #49
    Quote Originally Posted by 1tommygunner1927 View Post
    The long slotted part (is not fully seated in the rubber mount for the photo), the other end at the top attaches at the rear of the turbo compressor housing with one bolt.
    Ok now I understand thank you mate

  10. #50
    Sorry what spark plug are using fir turbo apllocation? Any experience with the pitch of 300 impeller to use to start ?

Page 5 of 11 FirstFirst ... 34567 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Map for 1000 cc with 15 or 18 psi turbo boost
    By DR2006RXP in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-27-2013, 11:02 PM
  2. SOLD FZR/FZS FXSHO ET Low Boost Supercharger Impeller 11.3 psi
    By prostocker in forum Yamaha Classifieds
    Replies: 2
    Last Post: 01-15-2013, 09:09 PM
  3. SOLD FZR or FZS ET Low Boost Supercharger Impeller 11.3 psi NEW
    By prostocker in forum Yamaha Classifieds
    Replies: 1
    Last Post: 12-30-2012, 09:50 PM
  4. 300x supercharger low boost psi problems !
    By Mike Redd in forum Kawasaki PWC Performance (4-stroke)
    Replies: 36
    Last Post: 07-28-2012, 02:22 AM
  5. 2007 250x low boost 9-10 psi
    By creativepuzzle in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 07-12-2009, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •