Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 47
  1. #11
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    9,396
    +1
    991
    Harbor Freight used to give them away with purchase. Not any more, but they're about $10. They're not high quality, but they will usually work in a pinch.


  2. #12
    Picking one up today after work. If it is the breaker, I can just wire an inline fuse could do the same job?

  3. #13
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    9,396
    +1
    991
    Yes. Just make sure it has the correct rating (and I don't know what it is).

  4. #14
    Got it, I will update you after i check it out this evening!

  5. #15
    Did a very redneck rig for testing purposes. It blew both of the breakers without popping them. Wired in temp fuses and the trim works and the button to start it works so yay. I only had time to hook it all back up and attempt to start it. It wouldn’t start even full choke and 10-15 seconds of turning over, so that’s my next issue to chase. I did have a similar experience as you though! The tube going from the oil tank to the pump is super dry rotted and was leaking oil in to the hull, so picking up a tube tomorrow as well as new spark plugs(just in case it’s that easy) I removed both tubes going to the carb and the return line had pressure and shot out fuel and the delivery line dropped fuel out of it, so I’m guessing the fuel is making it fine to the carb? Any common knowledge tips here?
    Last edited by GuppedUp; 08-12-2022 at 09:08 PM.

  6. #16
    Just another update. Put fuse holders inline, replaced the hose from the oil tank to the pump, new spark plugs, and cranked it for like 20 seconds and the battery got so low that it wouldn’t turn the starter anymore. Possibly a weak battery? Anywho, charging the battery now and trying to think of what else it could be. Cranked another 10 seconds and pulled spark plugs. They don’t look wet on the end. So, I guess the cylinder isn’t getting fuel.. input welcome
    Last edited by GuppedUp; 08-13-2022 at 06:09 PM.

  7. #17
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    9,396
    +1
    991
    One of the problems with these is hard starting when cold. You may have to crank it several times, just keep the cranking time short to prevent overheating the starter.

  8. #18
    Just like 10 second spurts? Are primer bulbs a bad idea on these skis?

  9. #19
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    9,396
    +1
    991
    Yes. I don't like the inline primer bulbs for PWCs. I'm afraid of flow restriction, but I don't know that that's really the case.

  10. #20
    I didn’t have time to mess with it yesterday. I guess I’ll try 10-15 second attempts at starting after work again today. I guess flow restriction is a possibility. I could be combated with a larger bulb, inlet/outlet hole diameters.

Page 2 of 5 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Maptuner V1 - looking for some guidance
    By davus in forum Seadoo Tuning
    Replies: 2
    Last Post: 01-21-2020, 06:34 AM
  2. Guidance Requested
    By johna56 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-28-2017, 08:55 PM
  3. I goofed so please help
    By sea-one in forum 2-Stroke Performance
    Replies: 8
    Last Post: 10-03-2014, 09:38 PM
  4. Need some guidance
    By phixer0364 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-06-2008, 11:11 AM
  5. i think I need some guidance...
    By dogger in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 04-29-2006, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •