Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2012
    Posts
    18
    +1
    2

    2010 RXTX260 stuck "reading key" and engine light after 5 seconds

    Ski ran fine a couple weeks ago when I had it out. Today I went to go out and hit the start button to wake up the ECU. As usual waited for the gauges to sweep and complete the boot. When the "reading key" message began I pushed on the key but did not hear the 2 beeps. This sometimes happens however, so I hit the start button anyway.

    The weird thing is the ski started but the "reading key" message was still scrolling. None of the gauges were working. Then I noticed the check engine light.

    After some additional troubleshooting, I determined that by hitting the start button from the off state, the gauges do their boot up, then the "reading key". After about 5 seconds the check engine light comes one. The ski will sit in this mode until it eventually times out after a couple minutes and goes back to sleep. However, If I insert the key and hit the start button it will start as noted above.

    My thought is the DESS post, but how is it recognizing the key to start but not recognizing the key to stop the "reading key"?
    Would a bad DESS post cause a check engine light?
    I tried disconnecting the battery for 5 minutes then trying again... no change. Does it need a longer disconnect time?

    I read on the forum about checking the trouble codes. Hit SEL 5 times with nothing (maybe older skis). Hit the MODE button then picked DISPLAY. It only shows CLOCK, RPM, and one other thing. No trouble code selection.

    Any thoughts or suggestions?
    Thanks in advance.

    Tim

  2. #2

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,452
    +1
    230
    It sounds like there's corrosion in one of the wire harnesses. Break the connections and do a visual inspection for it.

  3. #3

    Join Date
    Aug 2012
    Posts
    18
    +1
    2
    Finally got around to checking connections.
    -checked all fuses and bus bars. No corrosion or signs of moisture
    -pulled the harness feeding handle bars and gauge pod. All connections looked good.

    Connected the harness back up outside of the handlebars to the gauge clusters and switches, etc. Had the same symptoms.

    Disconnecting the gauge cluster, and the ski still did start after putting the key on the post. Ski will still not crank without the key, and does crank with the key.

    Seems to me it is seeing the key through the post, so probably not the post. Gauge cluster is very expensive (plus programming) so hate to buy one if that is not the problem.

    What should I do next? DESS post, or gauge cluster, or something else?

    Thanks
    Tim

  4. #4
    If the gauge is cracked and has had water in it, very common for the "key read" part of the mother board to be rotted out. Fixable if that's all that's wrong with the gauge, often there can be other issues.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. "Reading Key Message
    By Glade Rider in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-09-2020, 06:58 PM
  2. 2011 RXT Stuck on "Reading Key"
    By dsdirect in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-24-2020, 02:47 PM
  3. Sea-Doo "Reading Key" message
    By TSmith in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-13-2019, 12:36 PM
  4. "Reading Key" Message & Won't start
    By Davesavvy in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 11-06-2017, 10:15 PM
  5. WTB "Turn Key" 66V GP1200R Engine
    By rabzman in forum Yamaha Classifieds
    Replies: 10
    Last Post: 08-19-2008, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •