Results 1 to 5 of 5
  1. #1

    "Maint" and wrench flashing 5 times, then goes away

    I'd be grateful for help on this one... I haven't been in the boat since last year and everything ran great at the time. I'm getting the boat ready for the season and did an oil change and put in a fresh battery (the old one wasn't dead but I replace them after 4 years). Following these 2 things, I plugged in the key to get the # of hours to record in my maintenance long and noticed "maint" in the middle and a flashing wrench off to the right when I put the key in. They flash 5 times, then disappear. I start the engine right up and the "maint" goes away. I've never had the boat to a dealer and have always done the maintenance myself.

    Is this just an idiot light to tell me to do maintenance or is the computer throwing a code? I suspect it's just an "idiot light" since it goes away. TIA!


    2007 Seadoo Speedster 150, 215hp, 4tec
    -123 hours
    -brand new battery
    -brand new oil
    -will be changing spark plugs next - they have maybe 10hrs but are a year old
    -last proactive SC rebuild was at 106 hours

  2. #2
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,417
    +1
    891
    MAINT is an idiot reminder to service the SC every 100 hours. It will continue until it is reset by a CanDoo or BUDS. You will not see any performance changes with this reminder.


  3. #3
    Thank you so much... that is what I was hoping for... I'll find a dealer for the oil change next spring and have them clear the light at that time.

  4. #4
    Xspook's Avatar
    Join Date
    Jan 2014
    Location
    Space coast, FL (Brevard County)
    Posts
    1,816
    +1
    384
    Page 55


  5. #5

    Join Date
    May 2019
    Location
    Charleston SC
    Posts
    28
    Yep, same issue. You're stuck with it until you get it reset.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Old School Jet ski" Let the Good Times Roll" Kawasaki
    By Parrothead74 in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 09-21-2018, 02:44 PM
  2. flashing "SENSOR" five times...no code nor Candoo fault seen
    By Ken62465 in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-20-2015, 02:21 PM
  3. "Fuel" flashing and red light flashing?
    By martinworth in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 08-01-2014, 09:21 PM
  4. Replies: 1
    Last Post: 03-28-2012, 06:24 AM
  5. 2004 RXP - "MAINT" flashes on Dashboard
    By premlulla in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-07-2007, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •