Results 1 to 3 of 3
  1. #1

    Join Date
    May 2022
    Posts
    1

    04 xp di running on rear cylinder. Air injector issue?

    Need some help fellas. I have a 2004 seadoo xp 951 di. The ski is currently only running on the rear cylinder. I have narrowed it down to not getting fuel to the front cylinder. Both injectors are good. I can get it to run on the front cylinder only by swapping the electrical connectors on the air injectors. I thought maybe no signal from MPEM but i replaced it and im having the same issue. Any help would be greatly appreciated thanks.


  2. #2

    Join Date
    Nov 2020
    Posts
    16
    +1
    2
    sounds like your wiring is bad for that cylinder.

  3. +1 by:


  4. #3
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    5,233
    +1
    537
    Yep, you need to ohm the wiring from connector to AMP pin.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 xp di running on rear cylinder. Air injector issue?
    By Peejay9008 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 09-03-2019, 08:26 PM
  2. 01 GTX DI Air Injector Issue
    By borntopwn in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-11-2018, 08:55 PM
  3. bilge pump, no fire in rear cylinder issue
    By magnum in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-20-2013, 12:33 AM
  4. 951 di air injector issue
    By Matty-Mo in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-15-2011, 02:33 PM
  5. 4" rear air Intake-who's running?
    By rxpwhistler1 in forum 4-Tec Performance
    Replies: 67
    Last Post: 03-06-2008, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •