Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Apr 2021
    Location
    New Zealand
    Posts
    14

    Question 2014 Kawasaki STX-15F - Engine running rough after hitting waves

    Took the ski out on water today, ran very good for 15 min while hiting some long, large waves so got a bit of air (nothing serious though), at halfway point before turning back home notice it running rough, as if a cylinder stopped firing, only got up to 44mph instead of usual 58mph. No change in amount of smoke coming out of exhaust. Not sure what has happened. Started it out of water hooked up to fresh water hose and difficult to tell if it sounded any different. Definitly something wrong though.

    Spark plugs recently changed, fuel pressure is fine.

    Any tips or suggestions??

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,737
    +1
    909
    Are you getting any water in the hull? Sounds like it could be an exhaust leak.


  3. #3

    Join Date
    Apr 2021
    Location
    New Zealand
    Posts
    14
    No water in hull.

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,737
    +1
    909
    Loose plug wire perhaps?

  5. #5

    Join Date
    Apr 2021
    Location
    New Zealand
    Posts
    14
    Yea probably worth checking. Havent had the chance yet to check. Doesnt explain why this happeend when usually waves are way bigger and make for a rougher ride.

  6. #6
    KingKrab's Avatar
    Join Date
    Jul 2020
    Location
    NJ, USA
    Posts
    22
    +1
    5
    Quote Originally Posted by steve45 View Post
    Loose plug wire perhaps?
    This was my issue when jumping waves as well. Spark plug wires were arcing

  7. #7

    Join Date
    Apr 2021
    Location
    New Zealand
    Posts
    14
    Took the spark plugs out and noticed they all had quite a bit of carbon build up considering I only used the ski for 30 min. Have attached photos. Checked oil level which is within limits. Treid starting and removing one ignition coil at a time but couldnt find a cyilnder that was causing the issue.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_9345.jpg 
Views:	55 
Size:	22.9 KB 
ID:	480123   Click image for larger version. 

Name:	IMG_9344.jpg 
Views:	55 
Size:	25.9 KB 
ID:	480124   Click image for larger version. 

Name:	IMG_9342.jpg 
Views:	55 
Size:	29.2 KB 
ID:	480125   Click image for larger version. 

Name:	IMG_9347.jpg 
Views:	56 
Size:	24.0 KB 
ID:	480126  

  8. #8
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,737
    +1
    909
    Did you check the oil level after the engine had run for a couple of minutes and with the engine level?

    I carry a level in each of my 4-strokes that I put on top of the valve cover so I can get the engine level for checking the oil. Pull the dipstick, wipe it off, re-insert it halfway, level the engine, then stab the dipstick quickly and pull it out to get an accurate oil level.

    Too much oil is bad for the engine.

  9. #9

    Join Date
    Apr 2021
    Location
    New Zealand
    Posts
    14
    Yep did that as well, oil is halfway between low and full.

  10. #10
    Tropical Hoon Astrofizix's Avatar
    Join Date
    Jun 2021
    Location
    Whitsundays, Austopia
    Posts
    125
    +1
    10
    Could the waves have partially dislodged a vacuum line somewhere? Or even upset a manifold gasket or something like that?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 STX 15f burning oil/running rough
    By kevin11mic in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 05-19-2020, 06:35 PM
  2. 2010 Kawasaki STX 15F Rough Idle
    By Agsyke in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 08-22-2018, 11:38 AM
  3. 2006 kawasaki stx 15f engine inside a 2008 kawasaki stx 15f
    By Transport25 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 05-20-2017, 10:41 PM
  4. 2014 Kawasaki STX 15F dealer cost
    By merkdog in forum Kawasaki Open Discussion
    Replies: 44
    Last Post: 01-24-2014, 12:53 PM
  5. 2008 Kawasaki STX-15F Running Rough
    By Dallasmavs69 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 07-14-2010, 06:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •