Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    hbernier's Avatar
    Join Date
    Jun 2013
    Location
    Quebec, Canada
    Posts
    169
    +1
    2

    93 SL 650 impeller almost seized

    I finally removed the jet pump. I could hardly turn the drive shaft by hand. I thought that I had a bad bearing issue. I removed the impeller and was surprised to find out that the small shaft in the stator does rotate well without any wobbling. I've checked the wear ring and it fills not entirely smooth al around it. The impeller was in contact with the wear ring on certain spots and had too much clearance on other parts.
    I'm puzzled and don't know what to think of it. Any ideas?
    Thanks
    Click image for larger version. 

Name:	20211022_172208.jpeg 
Views:	81 
Size:	62.3 KB 
ID:	479949Click image for larger version. 

Name:	20211022_172254.jpeg 
Views:	84 
Size:	101.4 KB 
ID:	479950

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,658
    +1
    2,597
    The impeller outer edges are binding against the surrounding wear ring surface, correct?

    If so, it sounds like corrosion may have occurred between the stainless steel inner liner (the actual wear ring material) and the aluminum pump body. The corrosion pushes the liner inwards and it rubs on the impeller.

    The correct fix may to replace the wear ring, and perhaps the impeller. Since your 146mm jet pump is the early non-modular design it may differ from the 148mm in terms of what is possible.

  3. #3
    hbernier's Avatar
    Join Date
    Jun 2013
    Location
    Quebec, Canada
    Posts
    169
    +1
    2
    Quote Originally Posted by K447 View Post
    The impeller outer edges are binding against the surrounding wear ring surface, correct?

    If so, it sounds like corrosion may have occurred between the stainless steel inner liner (the actual wear ring material) and the aluminum pump body. The corrosion pushes the liner inwards and it rubs on the impeller.

    The correct fix may to replace the wear ring, and perhaps the impeller. Since your 146mm jet pump is the early non-modular design it may differ from the 148mm in terms of what is possible.
    Yes it is. I used penetrating oil to be able to turn the impeller by hand. You must be right about the diagnosis.
    The wear ring does not seem to be removable. Don't know what to do next...Replace the stator housing or the entire jet pump assembly or the wear ring if it is possible ?
    Thanks for your help!

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,658
    +1
    2,597
    My suggestion would be to source an entire 1994-1995 SL650 jet pump assembly. The impeller should be reasonably close to a match for your 1993 engine power (the 650 engine HP rating increased a bit in later years).

    Parts are more readily available for the modular 148mm jet pump and many of us are familiar with the 148mm pump. Your original 1993 146mm (non-modular) jet pump, not so much.

    As long as you end up with the SL650 impeller installed, you can source the other bits for a 148mm jet pump from almost any model and year Polaris. Most parts are mix and match.

    You can fit that 148mm impeller onto a stainless steel stator, or an aluminum stator. You have the option of installing a longer driveshaft and extended jet pump, or sticking with the current non-extended configuration.

  5. #5
    hbernier's Avatar
    Join Date
    Jun 2013
    Location
    Quebec, Canada
    Posts
    169
    +1
    2
    Thanks, I'll look into that.

  6. #6
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    5,048
    +1
    518
    I might have an extra 650 pump here,...freshwater.

  7. #7
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,658
    +1
    2,597
    Quote Originally Posted by Myself View Post
    I might have an extra 650 pump here,...freshwater.
    I do not remember whether the 146mm pump base on the early hulls will directly bolt up to the 148mm jet pump.

    Or does the entire old 146mm pump unbolt from the hull and be replaced by the 148mm jet pump assembly?

    A cross check of part numbers should be able to determine if the same part numbers (for the pump base mated to hull) was used in 1994 and in 1993.


  8. #8
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    5,048
    +1
    518
    The one I have is from a '92. It slips onto studs and has pipe nipples VERY much like a 2 stroke Seadoo pump.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20211026_164118.jpg 
Views:	15 
Size:	81.8 KB 
ID:	480022   Click image for larger version. 

Name:	20211026_164149_HDR.jpg 
Views:	17 
Size:	115.9 KB 
ID:	480023  

  9. #9
    hbernier's Avatar
    Join Date
    Jun 2013
    Location
    Quebec, Canada
    Posts
    169
    +1
    2
    Quote Originally Posted by Myself View Post
    The one I have is from a '92. It slips onto studs and has pipe nipples VERY much like a 2 stroke Seadoo pump.
    Does the impeller turn freely?

  10. #10
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    5,048
    +1
    518
    Yes, I've never seen that swelled wear ring issue here on freshwater machines.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help needed. Seized or not seized Yamaha suv 1200
    By CT06850 in forum Yamaha Open Discussion
    Replies: 37
    Last Post: 04-11-2019, 11:21 AM
  2. Impeller seized inside of pump wall. Fix?
    By Fandini in forum Polaris Open Discussion
    Replies: 16
    Last Post: 06-05-2013, 11:45 AM
  3. WTB - Parts sx 650 impeller
    By afc in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 02-26-2013, 08:36 AM
  4. impeller seized
    By brj833 in forum Honda Open Discussion
    Replies: 2
    Last Post: 06-10-2012, 08:45 AM
  5. 92 sl 650 impeller
    By diesel1985 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-07-2009, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •