Results 1 to 3 of 3
  1. #1

    2003 RXDI error code P0335

    Hi,
    my 2003 rxdi has been showing "maint" after starting.
    I have replaced the voltage rectifier after diagnosing it was bad, but that didnt entirely solve the problem.
    My candoo pro system is showing error code P0335. I understand this is for the encoder (crank position sensor) and means a wrong pattern was sensed.
    - How should I go about fixing this?
    From what ive read, ill need to remove the magneto cover and inspect the sensor, and potentially damaged teeth etc...
    - Also, it seems the cps is part of the stator assembly, is there any way to get it separately? could the stator also be shot?
    - what is the best way to access the magneto cover? Will I need to remove the engine?
    Thanks!


  2. #2
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,978
    +1
    510
    You can remove the exhaust, take bolts out of the front motor mount, unbolt the oil pump and lay it off to the right side, then lift up a bit on the engine and slide a block of wood under it for support. Then you can remove the front motor mount completely and remove the front cover....stator housing. I would think it a rare occurance for the pickup/crank sensor to be bad. More likely metal bits stuck to it or a rusty mess inside from water intrusion.

  3. #3
    The most typical cause of the P0335 encoder fault is loose mag end crank bearings. The second most common cause is encoder teeth issues, bent teeth, filings on teeth, rusty teeth. The third most common cause is cracked Reed valves. Yes, reed valves. Split reeds cause intake backfiring, which upsets the rotational speed, so the MPEM doesn't see the tooth pattern it expects at a certain point.

    First things first, pull engine, take off mag cover, put indicator on crank, should be zero axial play.

  4. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0335 error
    By krouchchocolate in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-17-2016, 08:59 PM
  2. Code P0335?
    By scantone in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-24-2015, 07:58 PM
  3. Help! Error code 13 on 2003 gp1300r
    By Kal2539 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-31-2013, 04:59 PM
  4. P0335 Error on 02 GTX RFI
    By pinchinpennies in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-26-2011, 07:51 AM
  5. Error Code 24 on 2003 FX140
    By amandamarie716 in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 06-19-2010, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •