Results 1 to 3 of 3
  1. #1

    Stage 3 svho misfire at 8k rpm

    My engine was replaced under warranty and now after breaking it in, Iíve realised there is a misssfire starting at 8000rpm and then gets worse. I need to check my afrs and will pull the rocker cover to check the timing.

    Compression is fine across all 4 pots (140psi) , I changed the plugs for new ones (looked fine though - nice dry light brown), I drained the fuel tank and put in fresh fuel.

    I have reflashed both the 17psi and 19 psi map and it still does the same thing. There are no error codes but exhaust water temp does shoot you to 76degrees when the mid fire happens.

    Just wondering if anyone has come across a similar issue.


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    38,318
    +1
    3,292
    Check your intercooler to make sure it's not leaking.

  3. #3
    I’m going to try that next. I hope not as it was a brand new Fizzle in there

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fz SvHo Misfire........
    By RIVERA RACING in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 06-09-2016, 07:33 AM
  2. Polaris 1050 misfire above 4000 RPM
    By keithhucklesby in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 05-20-2016, 01:14 PM
  3. 96 SL780 Misfire @4120 RPM
    By Nowi in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 05-25-2015, 07:22 AM
  4. High RPM misfire??
    By Boosted3s in forum 4-Tec Performance
    Replies: 26
    Last Post: 09-01-2011, 07:05 PM
  5. R12-X with misfire around 2000 rpm
    By hondaturboboy in forum Honda Open Discussion
    Replies: 5
    Last Post: 09-15-2008, 02:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •