Page 9 of 20 FirstFirst ... 789101119 ... LastLast
Results 81 to 90 of 197
  1. #81
    !!!! wave jumper !!!! 05_RXP's Avatar
    Join Date
    Jul 2011
    Location
    Hamilton, Ontario
    Posts
    809
    +1
    52
    Quote Originally Posted by DinoMite View Post
    He ran basically back to back same conditions and for close to the same RPM he went slower.

    Taking the seat off isn't going to change that...not to mention that's so JP Racing.
    Jp is a tool for one

    second thing to think about is Shallower pitch angle makes sense for slower speed. Shallower pitch angle does not make sense for same rpm. Something is choking motor back.


  2. #82
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,530
    +1
    368
    Quote Originally Posted by DinoMite View Post
    Ran today, full tank, belly full from lunch, 8200 occasionally saw blip to 8300. I"m guessing higher 82XX range. 77 one way 75.68gps, 78(blips to 79) 76.47 gps the other. 5-60 3.7X seconds. 82F water, 80air, salt water....stock prop
    I'm basically running very close to Your numbers in very similar conditions... but, low on fuel.

    Could not break 77 gps (76.9) @ 8300 with a couple blips to 8400 (78 with the occasional 79 showing on dash). Freshwater lake trimmed all the way up seems fastest.

    Just like on here, friends listing all my potential issues and just like jsmith, I keep asking them how I am running 8300 rpm with a corrupt tune, air starved engine or squirrel hanging out the intake grate?

    Was hoping to hear better news about this prop.

  3. #83

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    5,091
    +1
    1,025
    Quote Originally Posted by Vman View Post
    I'm basically running very close to Your numbers in very similar conditions... but, low on fuel.

    Could not break 77 gps (76.9) @ 8300 with a couple blips to 8400 (78 with the occasional 79 showing on dash). Freshwater lake trimmed all the way up seems fastest.

    Just like on here, friends listing all my potential issues and just like jsmith, I keep asking them how I am running 8300 rpm with a corrupt tune, air starved engine or squirrel hanging out the intake grate?

    Was hoping to hear better news about this prop.
    Yah I wouldn't expect them to be that far off in speed. 60lbs or (10 gallons) is 2mph all day long on every ski i've had. If it's not wear ring or impeller related I got nothing. Is your tabs and ride plate look fitted correctly. I can tell you just a little shimming on the tabs will cause some good drag. I'd just inspect the bottom real good, grate, make sure your nose cone on your impeller didn't spin off...I"ve had that happen a couple of times.

  4. #84
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,212
    +1
    2,659
    ***

  5. #85
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,530
    +1
    368
    Quote Originally Posted by DinoMite View Post
    Yah I wouldn't expect them to be that far off in speed. 60lbs or (10 gallons) is 2mph all day long on every ski i've had. If it's not wear ring or impeller related I got nothing. Is your tabs and ride plate look fitted correctly. I can tell you just a little shimming on the tabs will cause some good drag. I'd just inspect the bottom real good, grate, make sure your nose cone on your impeller didn't spin off...I"ve had that happen a couple of times.
    I hear Ya. Everything looks good to me, just like a brand new ski should... I'll climb under there again and have a good long look at everything.

  6. #86
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    9,212
    +1
    2,659
    Quote Originally Posted by DinoMite View Post
    You forgot the part where your walked 3 miles through snow up hill both ways to kindergarten.
    You're not far off on that!

    Quote Originally Posted by DinoMite View Post
    Yah I wouldn't expect them to be that far off in speed. 60lbs or (10 gallons) is 2mph all day long on every ski i've had. If it's not wear ring or impeller related I got nothing. Is your tabs and ride plate look fitted correctly. I can tell you just a little shimming on the tabs will cause some good drag. I'd just inspect the bottom real good, grate, make sure your nose cone on your impeller didn't spin off...I"ve had that happen a couple of times.
    Some basic items need to be addressed: ensure engine alignment is spot on, same for intake grate and ride plate, fill ride plate holes, check steering, get air into the hull.

  7. #87
    Martin RXT-X's Avatar
    Join Date
    Jul 2011
    Location
    Kemah Tx
    Posts
    763
    +1
    119
    Quote Originally Posted by DinoMite View Post
    He ran basically back to back same conditions and for close to the same RPM he went slower.

    Taking the seat off isn't going to change that...not to mention that's so JP Racing.

    Are you sure about that?? Seat and platform off big difference

  8. #88

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    5,091
    +1
    1,025
    Quote Originally Posted by Martin RXT-X View Post
    Are you sure about that?? Seat and platform off big difference
    Context may have got lost along the way, Nice of you take time out of your busy day and stop by the thread on page 9.

  9. #89
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,530
    +1
    368
    Quote Originally Posted by Martin RXT-X View Post
    Are you sure about that?? Seat and platform off big difference
    If You're already turning the proper rpm then it would stand to reason that the engine is not starved for air, hence no need to remove the seat or platform in order to induce more.

  10. #90

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    5,091
    +1
    1,025
    Quote Originally Posted by Vman View Post
    If You're already turning the proper rpm then it would stand to reason that the engine is not starved for air, hence no need to remove the seat or platform in order to induce more.
    My original point was seat off/seat on doesn't matter for the test...long as everything is basically equal when testing the impellers.

Page 9 of 20 FirstFirst ... 789101119 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 11 users browsing this thread. (1 members and 10 guests)

  1. Shane777

Similar Threads

  1. Great news!!! The new Solas 13/18 impeller is now available!!!
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 54
    Last Post: 02-05-2017, 08:27 AM
  2. WTB Skat 3 blade impeller for RXP 15.5/22.5
    By rxpredviper in forum Sea Doo Classifieds
    Replies: 15
    Last Post: 12-03-2010, 01:45 PM
  3. Skat 15.5/22.5 3 blade impeller on an RXP-X... Will it work???
    By t_hoang02 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-04-2008, 11:57 AM
  4. RXP-X 3/4 blade impeller
    By nickdog in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-06-2008, 03:16 PM
  5. Great news / worse news
    By 13xracing in forum Kawasaki PWC Performance (4-stroke)
    Replies: 51
    Last Post: 01-25-2007, 02:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •