Page 22 of 22 FirstFirst ... 12202122
Results 211 to 220 of 220
  1. #211

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    181
    +1
    43
    Quote Originally Posted by ptscon View Post
    Those numbers look a little weird, 15/25 at that RPM should be faster and curious as to your setup to be able to spin it that high. Is your GTR a 4Tec or Ace motor?
    Everything about a GTR is weird. Very small pump tunnel. Reason its hard to get um fast.300xx charger, stage 3 cam. Valves, springs, retainers. ‘17 1503 Ace motor

  2. #212

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    5,190
    +1
    1,069
    Quote Originally Posted by GTRD View Post
    Everything about a GTR is weird. Very small pump tunnel. Reason its hard to get um fast.300xx charger, stage 3 cam. Valves, springs, retainers. ‘17 1503 Ace motor
    My gut is thinking you may be experiencing some cavitation with that RPM/speed combo. Check and see if it's starting to look a little burnt looking on the edges of the blades. Those mods are respectable but wont turn that prop in a 300 ski at that RPM...something else is going on. We are talking about the Riva 15/25r impeller I assume.

  3. #213

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    181
    +1
    43
    Quote Originally Posted by DinoMite View Post
    My gut is thinking you may be experiencing some cavitation with that RPM/speed combo. Check and see if it's starting to look a little burnt looking on the edges of the blades. Those mods are respectable but wont turn that prop in a 300 ski at that RPM...something else is going on. We are talking about the Riva 15/25r impeller I assume.
    Yep, riva 15/25. Px and Tx skis have way bigger tunnels. I’m fighting to get water in. Its a gti hull.Think of a vacuum cleaner…motor speeds up when your hand is over the nozzle..not fighting air. This hull will never pump stuff. Processes more water then it can get.


  4. #214

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    5,190
    +1
    1,069
    Quote Originally Posted by GTRD View Post
    Yep, riva 15/25. Px and Tx skis have way bigger tunnels. I’m fighting to get water in. Its a gti hull.Think of a vacuum cleaner…motor speeds up when your hand is over the nozzle..not fighting air. This hull will never pump stuff. Processes more water then it can get.

    If you're not getting perfect suction then you're cavitating could be various factors, which then causing the higher RPM...what other option is there? You hit the limit of the pump at some RPM and you're just blistering the water. Take a pic of your impeller and see if has what looks like rub marks towards the edges.


    Cavitation is a phenomenon in which the static pressure of a liquid reduces to below the liquid's vapour pressure, leading to the formation of small vapor-filled cavities in the liquid. When subjected to higher pressure, these cavities, called "bubbles" or "voids", collapse and can generate shock waves that may damage machinery. These shock waves are strong when they are very close to the imploded bubble, but rapidly weaken as they propagate away from the implosion

  5. #215
    Team Bilford's Avatar
    Join Date
    Jul 2009
    Location
    Fort Worth, Texas
    Posts
    1,337
    +1
    194
    Quote Originally Posted by GTRD View Post
    Everything about a GTR is weird. Very small pump tunnel. Reason its hard to get um fast.300xx charger, stage 3 cam. Valves, springs, retainers. ‘17 1503 Ace motor
    You have heard of "there is no replacement for displacement". The same is true about intake pump volume. Your best solution to the limitations of the GTi hull is to get one of the hulls designed to feed a 300 pump. You simply can't turn your GTR into a RXP when you start with a GTi hull. The sum of the parts is more than just the engine.

  6. +1 by:


  7. #216

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    181
    +1
    43
    [QUOTE=DinoMite;3155669]If you're not getting perfect suction then you're cavitating could be various factors, which then causing the higher RPM...what other option is there? You hit the limit of the pump at some RPM and you're just blistering the water. Take a pic of your impeller and see if has what looks like rub marks towards the edges.

    Looks fine to me. Compare a gtr/gti intake grate to any 300 grate. Huge difference. Didn’t realize how much until we switched out one on a friends ‘20 px. Wish I took a side by side pic.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	B539B1F6-794A-47F6-AA34-F7EDC0A2D3D5.jpg 
Views:	179 
Size:	76.0 KB 
ID:	482179  

  8. #217

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    181
    +1
    43
    Quote Originally Posted by Team Bilford View Post
    You have heard of "there is no replacement for displacement". The same is true about intake pump volume. Your best solution to the limitations of the GTi hull is to get one of the hulls designed to feed a 300 pump. You simply can't turn your GTR into a RXP when you start with a GTi hull. The sum of the parts is more than just the engine.
    Not to be a dick but I don’t remember asking for a “solution”. I was asked of results from a certain prop and replied along with a response to why those results are what they are. Would be very easy to buy a 300 and make it faster than others. Buy a pre-made kit. No kits or database for mine. Had to figure stuff out along the way. Way more satisfying to wax 300’s and GP’s with a GTR. Really hurts their feelings.

  9. +1 by:


  10. #218

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    5,190
    +1
    1,069
    [QUOTE=GTRD;3155718]
    Quote Originally Posted by DinoMite View Post
    If you're not getting perfect suction then you're cavitating could be various factors, which then causing the higher RPM...what other option is there? You hit the limit of the pump at some RPM and you're just blistering the water. Take a pic of your impeller and see if has what looks like rub marks towards the edges.

    Looks fine to me. Compare a gtr/gti intake grate to any 300 grate. Huge difference. Didnít realize how much until we switched out one on a friends Ď20 px. Wish I took a side by side pic.

    It's does look really good. Looks a little discolored towards the impeller where it meets the ring, looks a little burnt to me. I suspect if you pull it, you'll have pitting on the edge of the impeller like every impeller I've run with a stainless ring. I don't seem to see that issue with plastic rings. My theory is the water is getting boiled at higher rpm when the impeller stretches and contacts ring edges causing that discoloration. You could just be getting loss of suction. Or maybe everything is fine...the 9100 rpm just doesn't make sense to me unless you have some cool weather or hp more than a stage 4, (big charger/cam) or combination of. Lot of speculation on my part, I just like to try to understand how one person gets more RPM then I did with less mods. I suspect the mystery will stay a mystery. Thanks for posting that pic. What's that green stuff though? You using triple guard grease on your splines? no nose grease boot?..can't really tell.

  11. #219
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    5,043
    +1
    1,099
    Probably just not enough water getting to to the pump making it spin without it translating into speed. My '12 PX did 86 on cluster at 89xx with 15/21 but I dunno these impellers pitches can be read a million ways I swear this "untouched" 15/21 looks like my impros pitched 15/24

  12. #220

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    181
    +1
    43
    [QUOTE=DinoMite;3155725]
    Quote Originally Posted by GTRD View Post


    It's does look really good. Looks a little discolored towards the impeller where it meets the ring, looks a little burnt to me. I suspect if you pull it, you'll have pitting on the edge of the impeller like every impeller I've run with a stainless ring. I don't seem to see that issue with plastic rings. My theory is the water is getting boiled at higher rpm when the impeller stretches and contacts ring edges causing that discoloration. You could just be getting loss of suction. Or maybe everything is fine...the 9100 rpm just doesn't make sense to me unless you have some cool weather or hp more than a stage 4, (big charger/cam) or combination of. Lot of speculation on my part, I just like to try to understand how one person gets more RPM then I did with less mods. I suspect the mystery will stay a mystery. Thanks for posting that pic. What's that green stuff though? You using triple guard grease on your splines? no nose grease boot?..can't really tell.
    Green is the solas cone. Blue is synthetic grease

Page 22 of 22 FirstFirst ... 12202122

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Great news!!! The new Solas 13/18 impeller is now available!!!
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 54
    Last Post: 02-05-2017, 08:27 AM
  2. WTB Skat 3 blade impeller for RXP 15.5/22.5
    By rxpredviper in forum Sea Doo Classifieds
    Replies: 15
    Last Post: 12-03-2010, 01:45 PM
  3. Skat 15.5/22.5 3 blade impeller on an RXP-X... Will it work???
    By t_hoang02 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-04-2008, 11:57 AM
  4. RXP-X 3/4 blade impeller
    By nickdog in forum 4-Tec Performance
    Replies: 2
    Last Post: 01-06-2008, 03:16 PM
  5. Great news / worse news
    By 13xracing in forum Kawasaki PWC Performance (4-stroke)
    Replies: 51
    Last Post: 01-25-2007, 02:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •