Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    You guess is as good as mine. I can put the pump in a vice, put a crescent wrench on the drive tab, and it won't turn. It's frozen solid. Perhaps it was the fact that it sat for a year and a half, but one would think something caused by lack of use would show us as soon as you tried to use it, but I tested the pump for rotation before I installed it on the new engine and it rotated smoothly and easily. After a few times running the engine for 10 seconds at a time to test everything, it failed.

    Edit: After re-reading the post, I think some context should be added. The pump seized and cause the flywheel nut to spin off and the flywheel to pop off the crank. I can see the confusion if you didn't have that piece of information that I detailed in another thread. It's not like it seized and there were no other consequences.
    Last edited by Viper Pilot; 10-03-2021 at 10:11 PM.

  2. #12
    Seth.parks014's Avatar
    Join Date
    Jul 2020
    Location
    Nashville, TN
    Posts
    13
    +1
    1
    Alrighty, I got a good 75 degree day to work on the ski. The used cylinder and piston are doing good so far! 122 PSI after testing. Now to find out WHY it seized.


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 08-04-2021, 11:27 AM
  2. 2000 Polaris Genesis electrical issue, I think.....
    By jwilvert in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-30-2014, 07:43 AM
  3. Need help with fuel issue on 2000 genesis (carb)
    By Dstox in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-15-2012, 03:31 PM
  4. Replies: 6
    Last Post: 04-25-2012, 08:31 AM
  5. Replies: 0
    Last Post: 04-15-2012, 01:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •