Results 1 to 4 of 4
  1. #1

    Post 1994 VXR pro - Loss of power/stuttering after warmed up

    Hi Guys,

    First post here - glad to have found this place. Just picked up a 1994 Yamaha VXR Pro, took it out for the first time and loved it!

    Issue I'm having... it runs great when it first starts up for about the first 10-15 minutes of riding. Full throttle rips! After it's warmed up I start to notice a loss of power. Almost like it's stuttering. It'll still go just fine, but not like it would when it was just getting going.

    I'm new to jet skis and 2 strokes in general. Know you can't diagnose from this info alone, but any tips on where to start? Spark plugs are probably first bet, just seems weird it would stutter after warming up, not vice versa.

    Thanks!


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,674
    +1
    891
    Welcome aboard, weeznur!

    Might be a problem with fuel tank venting. You might try cracking the fuel filler cap just a little and try it. Do this in smooth water so you don't get water in the fuel.

    Another possibility is an exhaust leak filling the hull with fumes. Try riding with the seat off and see if there is smoke inside, and see if the problem goes away.

  3. #3
    Quote Originally Posted by steve45 View Post
    Welcome aboard, weeznur!

    Might be a problem with fuel tank venting. You might try cracking the fuel filler cap just a little and try it. Do this in smooth water so you don't get water in the fuel.

    Another possibility is an exhaust leak filling the hull with fumes. Try riding with the seat off and see if there is smoke inside, and see if the problem goes away.
    Thanks, my man! I'll give these two suggestions a go next time I'm out. Appreciate the help.

  4. #4
    dannyual777's Avatar
    Join Date
    Jun 2008
    Location
    Lake Conroe (Montgomery,) Texas
    Posts
    887
    +1
    40
    weeznur, did you ever test these things that Steve mentioned?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vxr power loss/cavitation?
    By bryantjopplin in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 05-22-2013, 11:40 AM
  2. 1994 750 Sl loss of power
    By T-Trubble in forum Polaris PWC Performance
    Replies: 2
    Last Post: 08-12-2011, 08:06 PM
  3. 1994 750 Sl loss of power
    By T-Trubble in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-09-2011, 01:37 PM
  4. Loss of power and RPM after engine is warmed up ...
    By OBrienCJ in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-26-2011, 09:55 PM
  5. Another Problem, Loss of Power, Stuttering at top Speed
    By ercBOOSTED in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 06-29-2008, 05:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •