Results 1 to 4 of 4
  1. #1

    Join Date
    Dec 2020
    Posts
    4

    STX 15F - No Spark

    Hello Everyone,

    I have a blue 2005 Kawie STX 15F which turns over but no spark.

    A couple of years ago, the dash became water logged
    - I changed the dash with a new dash
    - no spark
    - both sensors ohm out correctly
    - the flip over switch seems to be acceptable as well

    A good friend who works on Harley's / snowmobiles / four wheelers (he used to own a honda dealership years ago) is trying to help find the issue but has not figured out the issue.

    We have read the imfamous end all STX thread but still can not find the issue.

    Any help would be appreciated.

    Thanks
    Scott

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,671
    +1
    891
    Go through the entire wiring harness, pull apart every connector and terminator plug. Use a lighted magnifier to inspect all the pins for corrosion, burn marks, etc. Kawasaki wiring connectors are bad about getting water in them and causing all kinds of problems.

  3. #3

    Join Date
    Dec 2020
    Posts
    4
    I changed out the ECU, now we are getting SPARK - YEAH. BUT ! I still can not get it pop / fire, even when I put fresh gas down the cylinders. Any help in figuring out this unit would be greatly appreciated. Thanks Scott

  4. #4
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    5,284
    +1
    400
    When it cranks over what does it do?

    Is the spark consistent or does it only do it for a few seconds then stops?

    Do you have 12v on the injectors?

    Do you have the ignition coils connected to the proper plugs on the main harness?

    What sensors did you check for resistance?

    Is there any other history on the machine other than the gauge being swapped?

    Sean


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawi 2008 STX 15F no spark?
    By kawi-jake in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 07-10-2020, 06:35 AM
  2. Kawasaki STX-15F vs Spark
    By WaterDR in forum Sea Doo Open Discussion
    Replies: 54
    Last Post: 03-25-2017, 06:51 AM
  3. STX-15F no spark
    By biscaynemark in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 06-13-2014, 05:46 PM
  4. Stx 15f no spark
    By rgsaenz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 06-20-2011, 03:52 PM
  5. how to change spark plugs stx 15f
    By imax in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 07-17-2008, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •