Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2021
    Posts
    1

    04 Polaris MSX 150 No RPM

    This is my first post. Tried to read all I could before, but please forgive me if I missed something.
    Friend of mine needed $. Sold me a 04 MSX 150. 104 hours. Starts and Runs. Both cylinders at 130+ PSI. Up to 3400 RPM in water. Checked cleaned MAP sensors, looked new. Checked cleaned plugs, they were oily. Checked/ cleaned intercooler. It was good. Hoses, turbo spins. No slop. Wastegate not seized. Opens by hand and closes with spring. Checked oil the proper way. Spot on. Coolant looks good. Read a thread that suggested taking the STTp ? Or whatever is called in the back. Took that Off and jumping purple to blue,/ white wire. Did it. Thought I had it. Fired it up and it hit some big RPMs (only ran 10-15 seconds out of water)
    Put it in the water, ran for 1 min up to 30 MPH. Then limp at 1600 RPM . cleaned some seaweed. Not much.
    Read another thread about disconnecting Turbo sensor. Not sure what it is or where it's located. Tried to disconnect one lead, that I assumed it was, but no difference.
    Kinda at a dead end and frustrated. Wish I bought a new model. Not something that's not made anymore and no one will work on. Sorry for complaining, please help. Thanks in advance.


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,417
    +1
    299
    Welcome to Greenhulk!

    You might try unplugging the exhaust temperature sensor, they are known to be flakey, which makes the ECU think that the engine is overheating.

  3. #3
    Postie1686's Avatar
    Join Date
    Jul 2020
    Location
    Saint Paul, MN
    Posts
    109
    +1
    3
    1600 is the limit for a over temp situation. As hiperco suggested you can try the one sensor. I have it circled in the photo below. My fear is that with it doing this at higher rpm it could be a head gasket issue.

    have you checked to see that you have coolant flow back to the expansion tank while it’s running?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	EFDD5256-FD51-4EBA-BBB0-E0D78453CC25.jpg 
Views:	24 
Size:	87.3 KB 
ID:	477031  

  4. #4
    Ye Ol Salty Dog's Avatar
    Join Date
    Oct 2017
    Location
    Lutz, FL
    Posts
    187
    +1
    34
    Update PPU/TPS
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1208CA59-ECA3-4543-9CBB-42A874FA2064.jpg 
Views:	42 
Size:	175.6 KB 
ID:	477060  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Msx 150 polaris limite rpm 6800 trm
    By steph06 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-07-2020, 08:58 AM
  2. MSX 150 polaris rpm 3550 tr/ minutes
    By Bra in forum Polaris Open Discussion
    Replies: 32
    Last Post: 07-18-2018, 01:06 PM
  3. Replies: 10
    Last Post: 05-11-2018, 09:03 AM
  4. polaris msx 150 reverse rpm limiter
    By James msx 150 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-03-2014, 09:14 PM
  5. polaris msx 150 burning oil limeted rpm help plz
    By ln69bt in forum MSX/Matrix
    Replies: 22
    Last Post: 04-09-2008, 10:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •