Results 1 to 3 of 3
  1. #1

    09 RXTX 255 VTS troubleshooting

    VTS is not working. Fuse was blown and replaced. VTS opened up and verified no water or corrosion. VTS beeps when I hold the button down but will not move up or down.

    Anyone have experience here before I wild goose chase this? Any schematics?


  2. #2
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    1,096
    +1
    71
    Replace the VTS motor.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    9,589
    +1
    1,762
    Quote Originally Posted by BIG CHIEF View Post
    VTS is not working. Fuse was blown and replaced. VTS opened up and verified no water or corrosion. VTS beeps when I hold the button down but will not move up or down.

    Anyone have experience here before I wild goose chase this? Any schematics?
    Open up the VTS and remove the trim rod completely from the unit and see if the motor turns.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. troubleshooting journy on first ski (2012 rxtx aS)
    By Wrxkyle in forum 4-Tec Performance
    Replies: 8
    Last Post: 11-19-2018, 07:32 PM
  2. VTS on RXP-X-255 is off center line... help
    By I8A4RE in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-17-2017, 07:56 PM
  3. Replies: 14
    Last Post: 10-06-2016, 12:32 AM
  4. 2008 RXT-x 255 VTS not working
    By jger in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-22-2016, 10:00 AM
  5. RXTX VTS Not working
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-27-2008, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •