Results 1 to 6 of 6
  1. #1

    Join Date
    Jul 2021
    Posts
    4

    MSX 140 Won't run unless fuel poured in the injectors.

    Hey Everyone,

    I'm thinking about buying a 2003 MSX 140 that I found for sale locally. Ski is in nice shape but won't run without fuel poured down the injectors. It has 208 hours on it and the guy is asking $4000 CDN, so I'd like to get the price down. My question for you guys is: What are some likely causes for there being no fuel to the injectors AND is the ski worth spending more time and money on. If I go and look at it closely I will compression test it myself. If they are low but even obviously it will get a top end refresh by me as well.

    Thanks,

    Steve

  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,403
    +1
    298
    If a DI machine only starts when primed, that is a classic symptom of low injector volts. (If it dies though, that could be due to a bad fuel pump).

    The voltage on the white/red wire (common to each injector and also present on the diagnostic plug) needs to be 18-20VDC during cranking. If it is low, either the stator/flywheel have an issue, or the EMM needs repair.

    $4000 CDN is a lot of money for a ski that doesn't run (even in CDN dollars aka monopoly money )


  3. #3

    Join Date
    Jul 2021
    Posts
    4
    Thanks for the reply! Yeah, I wouldn't pay the 4k thats for sure. EMM seems like I'd need to find one off a part out. The owner must have some insight into that being the problem. He says there is a new stator in it. Probably will let this one pass then! Thanks!

  4. #4
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,403
    +1
    298
    New stators are often miswired (I have a sticky about that in the tech tips forum).

    EMMs can be repaired (by me )

  5. #5
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,244
    +1
    2,552
    Quote Originally Posted by Rinesy View Post


    I'm thinking about buying a 2003 MSX 140 … It has 208 hours on it and the guy is asking $4000 CDN …
    Is this the original engine, never rebuilt? If so, 200 hours is getting towards end of life. It might make it to 250 hours, or it might make it to 209 hours.

    The cylinders are Nikasil plated, but the thing that tends to push the engine into rebuild are the crankcase bearings. The crankshaft end seals do age harden and eventually begin to leak air, which doesn’t hugely bother a Ficht engine but just adds to the list of aging factors.

    I would look at this MSX 140 as needing an engine rebuild sometime soon. Also the through-hull driveshaft bearing should be rebuilt every 100 hours or so, and has probably never been done.

    The fuel pump has a pressure regulator inside that needs to be reinforced. If this has not been done, it is mandatory to do so. These regulators can fall out (literally) without warning and quickly damage the running engine. The how-to info is listed on here.

    Overall, you must be Ok with doing all the maintenance and repair work yourself, and the diagnostics when needed.

  6. +1 by:


  7. #6
    sdlvx's Avatar
    Join Date
    Aug 2007
    Location
    Wisconsin
    Posts
    395
    +1
    24
    Nikasil can get worn out and flake off, leaving chunks of very dense metal bouncing around your crank case or your combustion chamber. I had some flake on one of my pros from the top, and I went to remove some of the nikasil to sleeve another cylinder, and the last half inch of nikasil just pinged off the bottom in the boring machine in a chunk that was about a third the circumference of the cylinder.

    Nikasil does go bad after some time, I would guess it heats up and expands at a different rate than the aluminum and weakens the bond over time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 MSX 140 won't idle
    By davlabo in forum MSX/Matrix
    Replies: 12
    Last Post: 07-09-2019, 09:38 AM
  2. MSX 140 won't idle
    By davlabo in forum MSX/Matrix
    Replies: 6
    Last Post: 03-28-2012, 09:05 PM
  3. WTB Looking for MSX 140 Fuel Injectors
    By dubl-z in forum Polaris Classifieds
    Replies: 0
    Last Post: 04-22-2011, 09:50 PM
  4. 03 MSX 140 RPM's won't get up
    By Lightning Rod in forum MSX/Matrix
    Replies: 6
    Last Post: 06-29-2010, 10:52 AM
  5. Won't start unless fuel poured into carb !
    By jdwcs in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 06-13-2010, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •