Results 1 to 5 of 5
  1. #1

    Solas impeller front seal, boot O-ring or is it needed?

    Hi all,
    I had my RXT 300 2021 out today and I felt a slight vibration, it quickly went away, but I decided to investigate anyway. It turned out that my solas impeller boot (SLA012) had unthreaded and was loose. The O-ring that is located on the aft side (threaded) is no longer there. I need a replacement o ring before a planed trip this week.
    Question: Where can I get a Solas O-ring quickly or will a generic O-ring from a local auto store work?
    I also saw a post that stated you don't need a drive shaft boot, is that true? I did notice some corrosion on the drive shaft and pump housing.

  2. #2
    Any o-ring will do, however I would either loc-tite it on or better yet run the factory rubber cone

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    38,261
    +1
    3,283
    You do not need the impeller nose cone.

  4. +1 by:


  5. #4

    Join Date
    Sep 2018
    Location
    Ellicott City, MD
    Posts
    164
    +1
    41
    Hate to disagree with Jerry but I would use the cone to help keep the grease in. Especially in salt/sand conditions. Had problems keeping them tight with loctite. Started using rtv silicone on the threads, hand tight and let dry overnight. No probs since and comes apart easy if need be. With or without oring.

  6. #5
    tiderider's Avatar
    Join Date
    Oct 2018
    Location
    Usa
    Posts
    1,097
    +1
    72
    With a flat head screw driver, tap across the threads on the cone to make small dents at 4 or 5 locations around it. Add red loctite and tighten it down. No more problems..


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Part number for Solas 13/18 impeller seal o-ring
    By DFW GP1800 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-18-2020, 07:27 PM
  2. Solas O ring for impeller seal SLA011
    By Drakeremoray in forum 4-Tec Performance
    Replies: 0
    Last Post: 04-27-2019, 06:49 AM
  3. Can't get impeller's rubber boot/seal on driveshaft 97XP
    By KevinSoCal in forum 2-Stroke Performance
    Replies: 0
    Last Post: 04-18-2018, 10:31 AM
  4. Impeller boot, new solas concord or original OEM off old impeller
    By Cathylongasta in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-05-2016, 12:53 PM
  5. Solas Impeller boot will not stay attached to impeller
    By Pamlico in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-16-2012, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •