Results 1 to 7 of 7
  1. #1

    How to tell if svho supercharger itself is bad

    Ok so I have a 2016 fx svho and I thought my clutch was bad since I was losing rpms so I put a new one in unfortunately that wasnt the problem after water testing. It sounds like my supercharger is hissing big time when I give it gas and there is hardly any power at all. I checked all the hoses and they are attached and tight. I have deans welded shaft in the supercharger so that little bearing isnt walking inside. What else inside could have let loose? This thing has been a pain in the butt trying to figure out why there is no boost and this hissing sound. Could it be the gen3 intercooler blow off valve? I think its my supercharger but I have no idea now. Any ideas would be greatly appreciated.

  2. #2
    WaterDR's Avatar
    Join Date
    Aug 2009
    Location
    Hudson, WI
    Posts
    1,625
    +1
    262
    You may have answered your own question…..if BOV isn’t closing you won’t get boost.

    Anyway to block it off and test?

  3. #3
    Figured the problem out. I didn't get the hose far enough on throttle body when I replaced it. It was leaking air. I am an idiot and just installed a new clutch for no reason. LOL At least I got some practice.


  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,214
    +1
    2,549
    Quote Originally Posted by Vikinsgrule View Post
    … 2016 fx svho and I thought my clutch was bad since I was losing rpms. … It sounds like my supercharger is hissing big time when I give it gas and there is hardly any power at all. I checked all the hoses and they are attached and tight.

    ... What else inside could have let loose? … trying to figure out why there is no boost and this hissing sound...
    Quote Originally Posted by Vikinsgrule View Post
    Figured the problem out. I didn't get the hose far enough on throttle body when I replaced it. It was leaking air. …
    Slipping supercharger clutch does not hiss.

    It is difficult to check the J hose where it connects to the throttle body from the intercooler.








    http://greenhulk.net/forums/showthre...=1#post2873423

  5. +1 by:


  6. #5
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    974
    +1
    193
    Quote Originally Posted by Vikinsgrule View Post
    Figured the problem out. I didn't get the hose far enough on throttle body when I replaced it. It was leaking air. I am an idiot and just installed a new clutch for no reason. LOL At least I got some practice.
    LOL, U think your a idiot? I’m a idiot, I replaced my clutch Friday with the new 21 clutch put it all back together ready to rock n roll for Saturday then realized I forgot to install the 2 button head bolts!! UGH, Had to do it all over again

  7. #6
    Dang that sucks! When my first clutch went out at 75hrs on my 2016 I put a new one in without changing those 2 bolts. It seemed to run fine while I don't know if this 2 button bolt was recommended back in the day or if its just something they found out later.

  8. #7

    Join Date
    Sep 2019
    Location
    Philadelphia
    Posts
    140
    +1
    19
    Quote Originally Posted by Vikinsgrule View Post
    Dang that sucks! When my first clutch went out at 75hrs on my 2016 I put a new one in without changing those 2 bolts. It seemed to run fine while I don't know if this 2 button bolt was recommended back in the day or if its just something they found out later.
    The button head bolts for chain tensioner are only needed when installing a revised 21 clutch on previous year skis,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad supercharger??
    By benjahw in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-06-2012, 11:24 AM
  2. 2005 RXT with Bad Supercharger
    By Jeffery73 in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-20-2012, 09:01 PM
  3. How can I tell if supercharger is going bad
    By sdman in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-30-2011, 09:13 PM
  4. supercharger gone bad
    By KeithThompson149 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 16
    Last Post: 08-07-2008, 06:33 PM
  5. Bad Supercharger?
    By hroger in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 05-21-2007, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •