Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11

    Join Date
    Apr 2021
    Location
    Santa Monica, CA
    Posts
    19
    +1
    1
    Quote Originally Posted by BLASTER 1 View Post
    Yup, that will do it everytime, what kind of a clamp you have there, looks different to me
    have no clue what kinda hose clamp it is. The mechanics mightíve thrown some new ones on when they took the engine out for the new stator. From 63 to 74.2 mph, Iím stoked it was a simple fix! Hopefully the BOV Iíve ordered will keep it from blowing off constantly.

  2. #12
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,212
    +1
    2,549
    Quote Originally Posted by wfirst View Post
    Ö Hopefully the BOV Iíve ordered will keep it from blowing off constantly.
    I have a pair of 2017 GP1800 with Riva Stage 1 Plus tunes.

    No blow-off valves, no hose disconnections of any kind in over 300 running hours so far.

    I did tighten and check all the hose clamps when these machines arrived new, and every so often go around and recheck them for tightness and correct hose and clamp positioning.

  3. #13
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,212
    +1
    2,549
    Quote Originally Posted by wfirst View Post
    Ö Hopefully the BOV Iíve ordered will keep it from blowing off constantly.
    I have a pair of 2017 GP1800 with Riva Stage 1 Plus tunes.

    No blow-off valves, no hose disconnections of any kind in over 300 running hours on each machine.

    I did tighten and check all the hose clamps when these machines arrived new, and every so often go around and recheck them for tightness and correct hose and clamp positioning.

  4. #14

    Join Date
    Apr 2021
    Location
    Santa Monica, CA
    Posts
    19
    +1
    1
    Quote Originally Posted by K447 View Post
    I have a pair of 2017 GP1800 with Riva Stage 1 Plus tunes.

    No blow-off valves, no hose disconnections of any kind in over 300 running hours on each machine.

    I did tighten and check all the hose clamps when these machines arrived new, and every so often go around and recheck them for tightness and correct hose and clamp positioning.
    Sounds like my 17í just wants to be a PITA then lol. I let my buddy hop on it and forgot to remind him to let off the throttle slowly, of course power loss happens again, thought it would be the same j-pipe on the bottom but it was the topside one this time.

  5. #15
    BLASTER 1's Avatar
    Join Date
    Jul 2015
    Location
    GRIDLEY, CA
    Posts
    974
    +1
    193
    Quote Originally Posted by wfirst View Post
    Sounds like my 17’ just wants to be a PITA then lol. I let my buddy hop on it and forgot to remind him to let off the throttle slowly, of course power loss happens again, thought it would be the same j-pipe on the bottom but it was the topside one this time.
    I would recommend that you check all your clamps: Air-Water, incoming and outgoing and your Exhaust

  6. #16
    I would get some t-bolt clamps (kinda like v bands) to put on there. Itís relatively cheap and you never have to worry about it again.

  7. #17

    Join Date
    Apr 2021
    Location
    Santa Monica, CA
    Posts
    19
    +1
    1
    Quote Originally Posted by BLASTER 1 View Post
    I would recommend that you check all your clamps: Air-Water, incoming and outgoing and your Exhaust
    just about every clamp was barely hand tight. nice mechanic work.

    Quote Originally Posted by Cole_1812 View Post
    I would get some t-bolt clamps (kinda like v bands) to put on there. It’s relatively cheap and you never have to worry about it again.
    just googled those, gonna have to order some. in the meantime I've double hose clamped where i can so i can still get back out on the water.


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Peak top speed vs Sustained top speed????
    By Parrothead74 in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 09-27-2018, 11:54 PM
  2. GP1800 Stage 2 video, on our race course and also top speed (85mph)
    By Turbo Dynamics in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-31-2018, 03:29 PM
  3. 2017 GP1800 VS 2017 FX SVHO Top Speed Test, Who's faster Stock???
    By Parrothead74 in forum Yamaha PWC Performance (4-stroke)
    Replies: 25
    Last Post: 04-08-2018, 12:26 AM
  4. 2015 RXP-X 260 only 63mph
    By JC7727 in forum 4-Tec Performance
    Replies: 50
    Last Post: 05-08-2017, 03:58 AM
  5. 1998 zxi1100 TOP SPEED 45..to 10 mph top speed
    By nzvlnr in forum Kawasaki Open Discussion
    Replies: 16
    Last Post: 09-13-2013, 07:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •