Results 1 to 10 of 10
  1. #1

    Join Date
    Aug 2020
    Posts
    11

    Help - Leaking Water

    I have a 2003 MSX140 and have found where its leaking water.

    The through-hull bearing that mounts to a sloped metal casting, that is bonded to the hull has de bonded itself.

    What do I do now? Has this happened to anyone else? Any tips (or products) to rebound it and seal it water tight?


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    3,748
    +1
    91
    https://parts.polarisind.com/Browse/Browse.asp

    According to the parts breakdown for "drive system" it appears the through hull seal bolts to the hull.

  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    45,663
    +1
    2,599
    Quote Originally Posted by KDF2020 View Post
    I have a 2003 MSX140 and have found where its leaking water.

    The through-hull bearing that mounts to a sloped metal casting, that is bonded to the hull has de bonded itself.

    What do I do now? Has this happened to anyone else? Any tips (or products) to rebound it and seal it water tight?
    Pirate33 had the MSX through hull base casting de-bond from the hull years ago.

    He posted how it was repaired.

  4. #4

    Join Date
    Aug 2020
    Posts
    11
    Quote Originally Posted by casey67 View Post
    https://parts.polarisind.com/Browse/Browse.asp

    According to the parts breakdown for "drive system" it appears the through hull seal bolts to the hull.

    here is a picture to help clarify. There are not any fasteners on it.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0071.jpg 
Views:	76 
Size:	86.7 KB 
ID:	475840  

  5. #5

    Join Date
    Aug 2020
    Posts
    11
    Quote Originally Posted by K447 View Post
    Pirate33 had the MSX through hull base casting de-bond from the hull years ago.

    He posted how it was repaired.

    I was able to dig up that old post but I did not see any details on products used or if he took it in somewhere.

    My first attempt was a some 3M marine sealant and some epoxy but that did not hold. I am having a hard time finding the right bonding material that want to stay adhered to the aluminum cast. Any suggestions?

    Might try to fiberglass wrap the casting once I find a better sealant/ bonding material. Again open to any suggestions.

  6. #6
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    1,510
    +1
    159
    I'd suggest you PM member bfarnam. Brett is very knowledgeable about different adhesives, especially 3M products. It is kind of crazy how many different variants there are of adhesives. I'm not sure what I have more of, tubes of different types of adhesives or tubes of different types of Loctite.

  7. #7
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    3,748
    +1
    91
    The bearing/seal housing bolts to that piece.

    That part shouldnt have alot of force on it, Make sure the bearing/seal isnt trying to lock up.

  8. #8

    Join Date
    Aug 2020
    Posts
    11
    Quote Originally Posted by martincom View Post
    I'd suggest you PM member bfarnam. Brett is very knowledgeable about different adhesives, especially 3M products. It is kind of crazy how many different variants there are of adhesives. I'm not sure what I have more of, tubes of different types of adhesives or tubes of different types of Loctite.
    Thanks will do. Started looking at more of those products and got overwhelmed haha.
    I hope to follow up soon with a working solution.

  9. #9

    Join Date
    Oct 2011
    Posts
    188
    +1
    29
    Find Plexus AO420...... I know that "On Hand Adhesives" sells it online.
    Contact Mark Cipolla for advice.

  10. #10

    Join Date
    Jun 2017
    Location
    St. Louis, MO
    Posts
    200
    +1
    15
    WOW the PM notification got REAL lost in my inbox.

    Did you ever find a marine structural adhesive that worked or do you still need a recommendation?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water leaking into hull ....
    By shwine617 in forum Honda Open Discussion
    Replies: 12
    Last Post: 07-27-2013, 12:25 PM
  2. Water Leaking Into Hull
    By Bertramfegg in forum 2-Stroke Performance
    Replies: 14
    Last Post: 03-24-2013, 10:40 AM
  3. sponsons leaking water...
    By Pale Rider in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-01-2010, 08:46 PM
  4. 03 GTX leaking water
    By Empirenj250 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-31-2008, 04:53 PM
  5. sl650 leaking water
    By MuTt1980 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-31-2008, 06:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •