Results 1 to 8 of 8
  1. #1

    Join Date
    Sep 2018
    Posts
    21
    +1
    2

    2019 RXT-X losing coolant.

    Hi. I was out a couple times last week. Every thing was fine till I pushed it full throttle for about a mile. Hot temp light came on and engine service light. Cooled down in 5 minutes and was able to ride 60 miles back at 1/2 throttle with no problems. No visible leakage in hull, oil is not milky. Put almost a liter in today and did a coolant leak down test. Held 15psi for 1/2 hr with no loss in psi, Seems to only push it at full throttle. Showed a P0298 fault code... hot oil cooler. Anybody have this problem? Have warranty but it will be tied up for a month before they can get at it. TYIA.

  2. #2

    Join Date
    Sep 2018
    Posts
    21
    +1
    2
    Also its not losing it thru the ride plate drain.

  3. #3
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    4,774
    +1
    1,029
    Take a water bottle and put the coolant overflow tube into it, tape it so it doesn't pop out and go for a ride. If you find coolant in the water bottle than it's your head gasket. Dumping coolant through the overflow tube at WOT is a sure head gasket failure.

  4. +1 by:


  5. #4

    Join Date
    Sep 2018
    Posts
    21
    +1
    2
    Thanks I will test it out.

  6. #5
    Did you fixed the issue? I'm also getting P0298 2020 rxt 300

  7. #6

    Join Date
    Sep 2018
    Posts
    21
    +1
    2
    After 6 weeks BRP has authorized new head and gasket.

  8. #7

    Join Date
    Sep 2020
    Posts
    2
    Quote Originally Posted by ptscon View Post
    Take a water bottle and put the coolant overflow tube into it, tape it so it doesn't pop out and go for a ride. If you find coolant in the water bottle than it's your head gasket. Dumping coolant through the overflow tube at WOT is a sure head gasket failure.
    I rode mine like this for a while and it siphoned back and forth the coolant because everything was on back order last year... Warped the head so bad had to shave 12 hundreths off the head ... Needless to say it WAS a head gasket now if it happens again I need a new head.

  9. #8

    Join Date
    Sep 2018
    Posts
    21
    +1
    2
    Latest update... new head still lost coolant. BRP authorized crate motor 9 weeks later. Runs great now.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2019 yamaha fx svho cruiser vs 2019 sea doo rxt x
    By Nb707 in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-06-2021, 02:02 PM
  2. Losing coolant after every ride
    By Joeyski in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 02-16-2020, 07:20 AM
  3. Replies: 21
    Last Post: 11-20-2012, 08:45 AM
  4. Losing coolant 1/2 catch can per tank of fuel
    By spinyard in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-24-2009, 10:38 PM
  5. Losing Coolant. Poppa Dawg Needs a Bone
    By Poppa Dawg in forum 4-Tec Performance
    Replies: 30
    Last Post: 10-17-2008, 02:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •