Results 1 to 6 of 6

Thread: Tach issues

  1. #1
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    996
    +1
    30

    Tach issues

    2005 Sportster NA. Tach does not function. Where does the signal wire get it signal? What type of signal is suppose to be there? Any way to test?

  2. #2
    Quote Originally Posted by Mighty Mouse View Post
    2005 Sportster NA. Tach does not function. Where does the signal wire get it signal? What type of signal is suppose to be there? Any way to test?
    I had the same thing it was both tacos and they were seized , got new ones fixed it

  3. #3
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    996
    +1
    30
    Were you able to find a aftermarket or did you go back with OEM?


  4. #4
    Quote Originally Posted by Mighty Mouse View Post
    Were you able to find a aftermarket or did you go back with OEM?
    Just ordered off eBay , I think they were like 400 each

  5. #5
    Quote Originally Posted by Mighty Mouse View Post
    Were you able to find a aftermarket or did you go back with OEM?
    i got this one locally in Australia - $84.95 delivered AUD this worked as per the original out of the box - also has an Hour meter

    https://www.roadtechmarine.com.au/ta...black/p/MGG110

    good luck fixing

  6. #6
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    996
    +1
    30
    I may just try a generic tach and hope the signal is generic as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pics of your Tiny Tach or Pet200 tach mounted on your FZR/S/SHO
    By JoeyDFZS in forum Yamaha PWC Performance (4-stroke)
    Replies: 25
    Last Post: 06-13-2015, 02:36 PM
  2. Anybody tried "Fast Tach" from the makers of Tiny Tach?
    By toyterrific in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 01-23-2013, 01:48 PM
  3. Mechanic input requested engine issues- issues with 99 xl700 with blown cylinder
    By mwinschel in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-30-2011, 12:55 AM
  4. pet tach issues
    By bigrob in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-24-2010, 08:56 PM
  5. Tach issues
    By amdeus in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-03-2007, 02:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •