Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,052
    +1
    821
    That thing looks like it got hot or something.


  2. #12
    if the resistance is the same, then everything is in order with him. I am engaged in the sale of this type of parts. your problem is different. when you turn on the ignition it will move a little bit. the essence of its work when the engine is cold, it is compressed, as the engine heats up, it expands. if you want to check whether it is fully extended or not, then start the engine, warm it up to operating temperature. then disconnect the chip from this sensor, then turn off the engine. remove the sensor and look at it. in general, this sensor is controlled by a temperature sensor.

  3. #13
    Pacer's Avatar
    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    553
    +1
    97
    Check valve clearance. Had one that died when I let off the throttle hard. Would idle if you let off slow. Had a few tight valves. Went down a couple shin sizes and it idled perfect after.

  4. #14
    ANTONYUK's Avatar
    Join Date
    Oct 2007
    Location
    Russia, Vladivostok
    Posts
    325
    +1
    50
    Quote Originally Posted by RIWaveRunner View Post
    I have for rec and racing this option
    http://foksmoto.ru/catalog/lodochnye...sikly/1419.htm

  5. #15
    MD628318 will get you one for 20 or 30 bucks. Got many years on my 20 dollar replacement. Google or e-bay it.


  6. #16
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,052
    +1
    821
    Quote Originally Posted by rotortiller View Post
    MD628318 will get you one for 20 or 30 bucks. Got many years on my 20 dollar replacement. Google or e-bay it.
    Dude, you're a life saver!

  7. #17
    Glad to be of assistance.


  8. #18
    RIWaveRunner's Avatar
    Join Date
    Sep 2015
    Location
    Marathon, FL
    Posts
    9
    +1
    1
    Quote Originally Posted by rotortiller View Post
    MD628318 will get you one for 20 or 30 bucks. Got many years on my 20 dollar replacement. Google or e-bay it.
    you, sir, are a gentleman and a scholar. THANK YOU!

  9. #19
    RIWaveRunner's Avatar
    Join Date
    Sep 2015
    Location
    Marathon, FL
    Posts
    9
    +1
    1
    Quote Originally Posted by rotortiller View Post
    MD628318 will get you one for 20 or 30 bucks. Got many years on my 20 dollar replacement. Google or e-bay it.
    I tested mine again yesterday and although the plunger does move on my motor, it does get very very warm/hot even at idle when the surrounding metal is still cool. I'm assuming that's not normal and mine needs to go either way

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2015 STX-15F Dies when let off throttle
    By bayoutunes in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-03-2020, 03:15 PM
  2. STX-15F randomly dies
    By Tom Doniphon in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 07-10-2020, 03:38 PM
  3. 15f dies when throttle pulled
    By jesseholmes708 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 01-25-2020, 07:06 AM
  4. sl750 dies out when hitting the throttle at idle
    By polarisman in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-11-2011, 11:43 AM
  5. STX-15F engine dies when throttle released
    By rcguy52 in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 08-07-2009, 12:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •