Results 1 to 10 of 24

Threaded View

  1. #1

    MSX 140 centre cylinder, apparent lean failure?

    Hi all , new to this site and looks like some good info. Had many cars and boats but just got my 1st ski. Am auto mechanic / engineer by trade.

    I bought a 2003 polaris msx140 ho here in western Australia not running with pto cylinder water induced.

    Just done full top to bottom rebuild and fired up great.

    Whilst checking the oil output to each cylinder at cranking speeds I thought it was a bit low after bleeding it so decided to add some premix for 1st start up around 15L .
    All was well on about a 1hr ride with low then mid throttle with occasional short wot . Run great and brought it home , used about 7L.
    Took it back out 3 days later added 30L 98 octane unleaded and all was good cruising around. On wot attempt for around 10 sec motor just cut to a lock. Fired back up 5 min later and ran ok then did something on wot again.

    Took home and tested . Comp 130 psi on pto and mag but zero centre. Stripped and had had burn on top of piston towards exhaust side with a hole and complete cylinder score grab.
    Looks definitely like a lean out not lubrication problem.

    Would run fine for ages on max half throttle but will lock on wot any longer than 10 sec only on middle cylinder.
    Checked fuel pressure on water while cruising and a couple stabs and maintained a steady 20 psi.

    Maybe crook injector and or ecu? Not sure if fuel reg mod has been done.
    Any advice would be appreciated.
    Last edited by K447; 01-19-2021 at 10:18 AM.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Max 140 Question
    By What is zwobbe in forum MSX/Matrix
    Replies: 2
    Last Post: 08-21-2019, 04:10 PM
  2. where to buy max 140 water temp sensor
    By Lathegreat1189 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 06-14-2016, 08:58 AM
  3. 2014 RXPX 68-140 Max Boost PSI
    By FallinOffHurts in forum 4-Tec Performance
    Replies: 34
    Last Post: 03-13-2015, 06:55 AM
  4. MSX 140 Running max speed 33 knots (52MPH)
    By aksobe in forum MSX/Matrix
    Replies: 5
    Last Post: 06-14-2011, 12:49 AM
  5. 03 MSX 140 missing and max 5,100 rpm
    By craig4him in forum Polaris Open Discussion
    Replies: 13
    Last Post: 08-12-2009, 11:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •