Results 1 to 8 of 8
  1. #1

    Going in limp mode with no faults shown - fx cruiser svho 2015

    Hi all, i have very odd issue with my fx cruiser svho 2015.

    If i ride for around 30 min then the max rpm is dropping down to 5000rpm.if i acellerate it goes to 5500 but drops back to 5000. Usually its drops gradually the longer i ride. From 7500 yo 7000 then 6500 and so on. Its not fixed in 500 rpm steps it just goes down until around 4500 to 5000.

    No alarms are coming up. The clutch is turning only in one direction, checked in hot engine condition.

    As soon it's cold again you can run up to 7500 max rpm and the same issue starts.

    All pissers are working. Oil side is hot but not boiling the others are just warm.
    Please advise


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    44,020
    +1
    2,386
    How many engine running hours on this clutch?

    How old are the spark plugs?

    What water conditions do you ride? Rough, smooth?

  3. #3
    250 h on the engine, oil change 25 hours ago, yes sometimes rough water. Today was the drop sudden after i was going over a wave. Small one, bov didn't come as i want unhooking. Riva intake grate helped a lot lot.

  4. #4
    Sorry spark plugs same time roughly 25 hours

  5. #5
    Clutch roughly 40 hours. That's why i checked the clutch in the hot state. If the clutch would be easy to change i might change it for a test but it a pain in the b....

  6. #6
    Clutch has around 40 h. That's why i check the clutch during the hour engine to see if the clearances are bigger

  7. #7
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    44,020
    +1
    2,386
    Quote Originally Posted by Jetski fx View Post
    ... spark plugs same time roughly 25 hours
    Might want to test with a new set of spark plugs, properly gapped. Easy to do, not expensive. Sometimes a spark plug just goes bad, might be affected by heat.

    Fingers crossed 🤞

  8. #8
    Thanks for that, i will try

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Limp mode
    By Jspeeddemon in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 05-31-2017, 09:44 AM
  2. LIMP MODE
    By luca in forum Sea Doo Spark
    Replies: 3
    Last Post: 09-24-2014, 03:45 PM
  3. limp mode!
    By german06 in forum Honda How To & FAQs
    Replies: 2
    Last Post: 05-11-2010, 04:10 PM
  4. Limp mode or Not to Limp mode on a 1995 SL
    By Feral in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-18-2008, 11:34 PM
  5. Limp mode?
    By tinselhair82 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-22-2007, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •