Results 1 to 2 of 2
  1. #1

    2011 rxt-as not powering up

    newbie here. I have a 2011 RXT-X-AS that wont power up by the pushbutton or by attaching the key to the dss. Prior to today either action would allow the instrument cluster to energize and would get 1 or two beeps depending if key was in place or not. The ski started and ran without exception prior to today. So, I took the cover off the 12 aux relay in the fuseblock and manually close the contact on the relay to obtain the +12 V auxiliary power and then instrument cluster will power up at that point, but get a reading key message with either key (regular or learning). I checked all fuses and are good. Pulled all of the bus bars with zero corrosion on any of them. Its like the computer and the display are not communicating at all. I assume under normal operation the computer turns on the relay in the fuse panel to power up the display and allow for initiation of a start sequence but not 100 sure. Any recommendations would be appreciated.

  2. #2

    Join Date
    May 2020
    Location
    Raleigh NC Area
    Posts
    79
    +1
    1
    Quote Originally Posted by RXT-AS 2011 View Post
    newbie here. I have a 2011 RXT-X-AS that wont power up by the pushbutton or by attaching the key to the dss. Prior to today either action would allow the instrument cluster to energize and would get 1 or two beeps depending if key was in place or not. The ski started and ran without exception prior to today. So, I took the cover off the 12 aux relay in the fuseblock and manually close the contact on the relay to obtain the +12 V auxiliary power and then instrument cluster will power up at that point, but get a reading key message with either key (regular or learning). I checked all fuses and are good. Pulled all of the bus bars with zero corrosion on any of them. Its like the computer and the display are not communicating at all. I assume under normal operation the computer turns on the relay in the fuse panel to power up the display and allow for initiation of a start sequence but not 100 sure. Any recommendations would be appreciated.
    Hey! Just went a very similar situation trying to revive an abandoned 2010 RXT-X 260. When I hit the start button to wake it up, all I would here is the click of the relay in the fusebox, no gauges or anything. My issue turned out to be a poor connection of the purple wire going from the gauges into the button of the fusebox. Temporarily solved by wiggling the wires under the fusebox to make the connection again. Hope that helps.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 Seadoo GTS 130 4-tec not powering up! Nothing
    By KwAJ305 in forum 4-Tec Performance
    Replies: 50
    Last Post: 11-12-2020, 02:56 PM
  2. Replies: 4
    Last Post: 05-30-2020, 02:54 PM
  3. 2012 RXT X - Cluster Powering Off
    By jgruj in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-21-2018, 08:36 PM
  4. Replies: 4
    Last Post: 07-17-2011, 12:07 PM
  5. 2011 RXT X 260as Versus 2011 RXT X 260
    By RUSTYSKI in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 04-08-2011, 09:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •