Page 19 of 19 FirstFirst ... 9171819
Results 181 to 189 of 189
  1. #181
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    107
    Quote Originally Posted by mittens View Post
    Being told the Exhaust temp/water sensor can be just zip tied in the hull and plugged it. as it only trips when unplugged or over temp/ is this true?

    Anyone have response?


  2. #182
    I got a small block of alloy drilled and tapped two water line connections and the sensor into it. that way its still kinda doing its job monitoring the water temp coming out.

  3. #183
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    107
    But do you have to do that? or can you just leave it plugged in, and not wet?

    Also some progress, as ski is at new welder, so hopefully see some progress on my pipes.

  4. #184
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    107
    A little progress, not crazy but some. Once the outer rim is finished being tigged, will move on to up pipe. Wanted this done first so we had the full size of turbo/housings/wastegates so location is turbo is accurate. Wanting to mount it as high as possible but just below the rear storage bucket. aslo will keep with all close the back of the midwall so less leverage on all the pipes. Can see the one bung is on bottom, hopeful will drain well.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	15CD41A2-DF04-459E-97DC-BF363B99E892.jpg 
Views:	121 
Size:	55.2 KB 
ID:	472628   Click image for larger version. 

Name:	C1BF0E23-6FB2-49A6-9633-BB68F4B4D7BB.jpg 
Views:	124 
Size:	58.5 KB 
ID:	472629  

  5. #185
    seems like a very good job

  6. #186
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    107
    Thanks, I got a video of I the other day when he was pressure testing it. Was using 150 psi.. so should be good ha. Need him to get the pipes done. weather is warming this week!

  7. #187

    Join Date
    Feb 2021
    Location
    Belgium
    Posts
    11
    I turboed an ex and had it plugged in and zip tied, no codes on the dash.

  8. #188
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    107
    Quote Originally Posted by raffshore View Post
    I turboed an ex and had it plugged in and zip tied, no codes on the dash.
    Thank you very much for the response!

  9. #189
    Quote Originally Posted by raffshore View Post
    I turboed an ex and had it plugged in and zip tied, no codes on the dash.

    That would be so rad, you have any build pictures? You had what plugged and zipped tied?

Page 19 of 19 FirstFirst ... 9171819

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SVHO shopping and timing chain thoughts.
    By mittens in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 12-30-2019, 01:27 PM
  2. FS 2014 Yamaha SVHO Turbo Race Ski - Turbo / Custom Build
    By Socaloffshore in forum Yamaha 4 Stroke Skis
    Replies: 4
    Last Post: 12-26-2018, 02:57 PM
  3. FS Yamaha SVHO Turbo Race Ski - Turbo
    By Socaloffshore in forum Yamaha 4 Stroke Skis
    Replies: 0
    Last Post: 10-16-2018, 03:31 PM
  4. thoughts on these upgrades for my fx cruiser svho
    By SVHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-04-2017, 01:34 PM
  5. Turbo chat and thoughts on kits to buy!
    By Water4fire in forum 4-Tec Performance
    Replies: 55
    Last Post: 06-19-2008, 12:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •