Page 18 of 19 FirstFirst ... 816171819 LastLast
Results 171 to 180 of 189
  1. #171
    ShawnInFL's Avatar
    Join Date
    May 2015
    Location
    Florida
    Posts
    150
    +1
    13
    I'm sure it's nothing, it just caught my eye. Damn good find on the ski. Hell, I have 40 on my 2020 and winter is the only reason I don't have more. I'll check back with ya on hrs this time next year. I'm sure you'll be making use of that turbo. Amazing to me how folks have these skis and never use them. Yours looks like it's never seen salt, that's the plan with mine as well. Keep us posted!

  2. #172
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    108
    I had a 2009 SHo modded for a few years and was about to start down the big wheels or turbo path. and wanted to get a better base platform. Was shopping ONLY 2016 FZ.. and really only FZS with white top and black bottoms. Looked at this one for months and kept shopping as it was in Arizona.... finally said F it, and bought it and had it shipped to me ha. Salt wise I ride fresh water 99 % of the time, but about once a year I take a trip south to pretty water and ride it in salt. Just washed, flushed, and fully detailed after even the bilge is soaped and cleaned if I go.

  3. #173
    ShawnInFL's Avatar
    Join Date
    May 2015
    Location
    Florida
    Posts
    150
    +1
    13
    Wow, AZ! Long haul from AL. Now I know how you found such a great ski. A very wide search. Same here. Had a 2009 SHO 340 hrs. No mods, zero repairs! That ski was always fun and best of all, super reliable. That being said, I wanted to do the mods, wanted to start fresh. Picked up the 2020 and figure I can squeeze another 100k out of my 2004 Denali. It only has 257k on it right now. lol Reminds me of this old Mastercraft Ad. Click image for larger version. 

Name:	205 (2001)  X-Star - priorities.jpg 
Views:	30 
Size:	92.7 KB 
ID:	471538

  4. #174
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    108
    Now to get my fat arms under the exhaust to get the oil pressure sensor off the Riva T, and remove the T.

    and also get my fat arms under the intake manifold, and install the 5/8th T for my oil return.

  5. #175
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    108
    Quote Originally Posted by mittens View Post
    Question on the oil feed.

    once I remove the T fitting for the riva gen 3 shaft. And remove the oil feed line. Does it matter which port I use for the sensor vs turbo feed?

    before sensor is on top, feed on bottom. But seems would make life easier if I swap them.
    After removing the sensor and then the T. the two holes are not threaded the same. SO just posting this incase somewhere later someone runs across this. You cant not run the oil pressure sensor in the bottom hole. only fits the top.

    And a strait AN fitting M10x1.25 on block, going to a strait AN hose, 45, or 90 does not look like its going to clear the oil cooler on a 2016 svho. going to have to find a Banjo or 45 fitting.
    Last edited by mittens; 02-19-2021 at 04:27 PM.

  6. #176
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    108
    Quote Originally Posted by ShawnInFL View Post
    I'm sure it's nothing, it just caught my eye.
    Pulled block off back off (dropped a bolt in bottom of bilge...) and inspected its in dead a reflection, haha paranoia owns me at times.

  7. #177
    ShawnInFL's Avatar
    Join Date
    May 2015
    Location
    Florida
    Posts
    150
    +1
    13
    Cue the Kinks - Destroyer! Better safe than sorry bro! Can't imagine the $'s you're saving doing this yourself. Keep us posted!

  8. #178
    keep us informed of your progress

  9. #179
    mittens's Avatar
    Join Date
    Mar 2018
    Location
    Huntsville, AL
    Posts
    1,026
    +1
    108
    Being told the Exhaust temp/water sensor can be just zip tied in the hull and plugged it. as it only trips when unplugged or over temp/ is this true?

    Welder put me off a this week as the 2 race car prodjects have him slammed working to get them to a South GA race late this week. hopefully Monday.... these damn pipes are my and anyone else hold up but hopefully once done should be plug and play and run some waterlines.

  10. +1 by:


  11. #180
    ShawnInFL's Avatar
    Join Date
    May 2015
    Location
    Florida
    Posts
    150
    +1
    13
    Sucks to hit another welder wall, sorry to hear it. In your downtime, might as well get the electronics worked out. You know you want it, make it happen Mittens!! Would be damn hard to say no if I had a turbo setup. Love me some gadgets!

    https://www.fueltech.net/collections...et-ski-package



Page 18 of 19 FirstFirst ... 816171819 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SVHO shopping and timing chain thoughts.
    By mittens in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 12-30-2019, 01:27 PM
  2. FS 2014 Yamaha SVHO Turbo Race Ski - Turbo / Custom Build
    By Socaloffshore in forum Yamaha 4 Stroke Skis
    Replies: 4
    Last Post: 12-26-2018, 02:57 PM
  3. FS Yamaha SVHO Turbo Race Ski - Turbo
    By Socaloffshore in forum Yamaha 4 Stroke Skis
    Replies: 0
    Last Post: 10-16-2018, 03:31 PM
  4. thoughts on these upgrades for my fx cruiser svho
    By SVHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-04-2017, 01:34 PM
  5. Turbo chat and thoughts on kits to buy!
    By Water4fire in forum 4-Tec Performance
    Replies: 55
    Last Post: 06-19-2008, 12:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •