Results 1 to 2 of 2
  1. #1

    Ultra 150 started just clicks

    Iíve been have trouble with my 2000 ultra 150 off and on with the starter. Iíve had it checked by the dealer and they just cleaned the battery terminals. Battery is fully charged all the lights and dash comes on, trim works. But the started button when pushed just makes a clicking sound.


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,980
    +1
    806
    Could be a loose/dirty connection on the ground connection to the engine, or the battery connection on the relay box. Could be a corroded jet pump liner. Could be a bad starter relay, or a bad starter motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel/Choke Knobs interchangable for 99' Ultra 150 to 00' Ultra 150
    By Meen95z in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-20-2015, 07:43 AM
  2. today started the break in and had problems ultra 300x
    By elpeladodelsamba in forum Kawasaki PWC Performance (4-stroke)
    Replies: 78
    Last Post: 06-02-2011, 07:17 PM
  3. WTB WTB STXR/ULTRA 150 electrical box and started solenoid box
    By icerocket1286 in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 11-03-2010, 09:35 PM
  4. Stock Kawi Parts for SXR, Ultra 250x, Ultra 150, and Xir
    By ev0klr in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 12-15-2008, 11:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •