Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Rxp-x300rs xxx

  1. #11
    Jarek's Avatar
    Join Date
    Oct 2019
    Location
    Cork, Ireland
    Posts
    31
    Thx for this hint.
    I know there will be lot of test.

  2. #12
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,153
    +1
    443
    A cam really wakes that charger up too

  3. #13
    I had '16 RXP 300 with stage-3-kit and Vtech tuning. No regulator. Just orginal fuel pump and 1100-injectors. I rid 50 hours with it and rebuilt engine two times because of connecting rod upper bushing and oil cooler. But I never saw any signs of running lean or detonation. The fuel is 98E here in Finland though.

  4. #14
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    4,322
    +1
    927
    Quote Originally Posted by micco View Post
    I had '16 RXP 300 with stage-3-kit and Vtech tuning. No regulator. Just orginal fuel pump and 1100-injectors. I rid 50 hours with it and rebuilt engine two times because of connecting rod upper bushing and oil cooler. But I never saw any signs of running lean or detonation. The fuel is 98E here in Finland though.

    If you're referring to Riva stage-3 kit than that's the 135 wheel, the XXX is 142.

  5. #15
    Jarek's Avatar
    Join Date
    Oct 2019
    Location
    Cork, Ireland
    Posts
    31
    May i ask what was the symptoms of upper bearing failure? Knocking in engine? Oil pressure light?
    Cheers

  6. #16
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,153
    +1
    443
    I got 88hrs with 142, before plasma peeled

  7. #17

    Join Date
    Sep 2017
    Location
    London UK
    Posts
    210
    +1
    33
    Quote Originally Posted by moparguy View Post
    I got 88hrs with 142, before plasma peeled
    Did you go with sleeves after?

  8. #18

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,877
    +1
    995
    Quote Originally Posted by moparguy View Post
    I got 88hrs with 142, before plasma peeled
    Feels like you ran it to lean.


  9. #19
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,153
    +1
    443
    Quote Originally Posted by DinoMite View Post
    Feels like you ran it to lean.
    Never lean, never went WOT before logged and dialed in with Jesus G. The plating lifted below the skirts, on cyl 2 and 3, oh well have a sleaved block now hahaha.

  10. #20
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,153
    +1
    443
    Quote Originally Posted by 711jrp View Post
    Did you go with sleeves after?
    Chris(slow91) @ Eastside sleaved my block

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Next Charger for 04 RXP? Rude3/ET/XXX?
    By snowrunner in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-07-2017, 09:27 AM
  2. Seadoo rxp-x300rs intercooler damge
    By Haitham in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 01-10-2017, 10:23 AM
  3. flash and injectors for xxx charger? 2004 rxp
    By toxicgun in forum 4-Tec Performance
    Replies: 6
    Last Post: 02-21-2015, 02:54 AM
  4. riva xxx charger - 2007 rxp charger upgrade
    By jerryspringer in forum 4-Tec Performance
    Replies: 15
    Last Post: 12-20-2011, 07:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •