Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24
  1. #21
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,337
    +1
    379
    The in tank filter and sock are easily sourced. I buy them from Jetskiplusllc. The inline crosses to a Baldwin BF1049. You will also need stainless full circle nut bolt type clamps (2 per side oriented 180* from each other) or oetiker clamps and the proper tool or a large pair of dulled side cutters.

  2. #22
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    659
    +1
    16
    I always check fuel as the first culprit on Di's. Just what I do.

  3. #23
    Team Bilford's Avatar
    Join Date
    Jul 2009
    Location
    Fort Worth, Texas
    Posts
    918
    +1
    110
    Quote Originally Posted by diamondwatercraft View Post
    I always check fuel as the first culprit on Di's. Just what I do.
    Fuel, as in quality or quantity? I have run two or three tanks through it and thought the issue was gone, but it continues to show up frequently. I can't judge quantity until I can T in a line and gauge.


  4. #24
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    659
    +1
    16
    Quantity, "T" into the line and use a gauge to make sure your at 107 psi. I took a old line I had and made a tool just for it. If you don't have that 107 your not getting full power. After that checks out I would check the air pressure. I believe the spec is 90 psi. These two things are what makes the old DI's run.
    Last edited by diamondwatercraft; 12-02-2020 at 06:39 AM.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 RXT lost 300-500 RPM
    By madmadeline in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-23-2017, 11:23 PM
  2. Replies: 113
    Last Post: 05-08-2013, 05:43 AM
  3. Lost 300 RPM.....
    By Sea Dood in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-05-2012, 09:06 PM
  4. Replies: 7
    Last Post: 11-07-2011, 06:48 PM
  5. any suggestions? same rpm lost 5-7 mph from almost 90 to low 80s same rpm
    By green08 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-30-2010, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •