Results 1 to 3 of 3
  1. #1

    Low performance 08 kawasaki ultra250x.

    Hello, Good Morning.


    I need help on 08 kawasaki ultra250x.

    I bought the jet in March with 89 hours. The first time we put the jetski in water was going +/- 50km/h.
    After that we changed the impeller because the one that was at jetski was a little beat damaged. So once we open the housing we just also the pump bearings.
    We changed the supercharger bearing.
    The ski was performing better but after that I had issue on the intercooler. What putting water inside. We fixed, we took out the damp valve and replaced with a block plate.
    we did a normal maintenance oil, filter and spark plugs.
    We put back on the water last weekend but the jetski was not going more then 40km/h.

    Any advice on what else I can check?


    ***sorry about the ingles****

  2. #2
    dcuhpw's Avatar
    Join Date
    Jan 2019
    Location
    Guam
    Posts
    705
    +1
    51
    Quote Originally Posted by Karn View Post
    Hello, Good Morning.


    I need help on 08 kawasaki ultra250x.

    I bought the jet in March with 89 hours. The first time we put the jetski in water was going +/- 50km/h.
    After that we changed the impeller because the one that was at jetski was a little beat damaged. So once we open the housing we just also the pump bearings.
    We changed the supercharger bearing.
    The ski was performing better but after that I had issue on the intercooler. What putting water inside. We fixed, we took out the damp valve and replaced with a block plate.
    we did a normal maintenance oil, filter and spark plugs.
    We put back on the water last weekend but the jetski was not going more then 40km/h.

    Any advice on what else I can check?


    ***sorry about the ingles****

    How much boost are you getting on the gauge? Also, what is you native language?

  3. #3
    Hello, Good Morning,

    im getting of boost 7000 to 8000 rpm, i get 10 psi .but jetski is getting stack btw 4000 to 5000 with 5 to 7 psi of boost.
    yesterday we put the jetski on the water, was doing fine but at some point after +/- 60km/h was going up and down dropping to 20 going up again. we did the test of the fuel pump. the fuel pump is sending 100ml to the injectors.

    im thinking to buy a new fuel pump because i was reading on the manual, the pump must send 175 ml.is that correct?

    my native language is portuguese.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. low performance 08 kawasaki ultra250x.
    By Karn in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 10-22-2020, 07:25 AM
  2. New owner of 07 Kawasaki ultra250x.
    By palacios289 in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 07-10-2019, 11:32 PM
  3. FS 2007 Kawasaki Ultra250x
    By ModularJunk in forum Kawasaki Skis
    Replies: 0
    Last Post: 06-20-2012, 06:41 PM
  4. 07 Kawasaki Ultra250X $3,200
    By Gus13letter in forum Kawasaki Skis
    Replies: 71
    Last Post: 04-13-2009, 09:48 AM
  5. TLR Performance porting available for 15F/Ultra250X
    By tlrperf in forum Kawasaki PWC Performance (4-stroke)
    Replies: 18
    Last Post: 05-16-2007, 07:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •