Results 1 to 4 of 4
  1. #1
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    Moyock nc.
    Posts
    288

    2012 gti issues ........still

    ok I've posted about this ski (2012 gti 130 se) numerous times long story short ski was sunk engine has been gone through and i still don't have full power 35-40mph max here is what has been done

    -key verified normal key w/canndoo pro
    - plugs and coils changed
    - fuel injectors cleaned (not professionally but were removed voltage applied and cleaned injectors all spray fine both on the rail and off)
    - changed throttle body
    -changed ECU
    - changed rt lever tps
    - compression at 165,165,175
    - oil and filter changed (multiple times)
    - water pump rebuilt
    - both oil pumps rebuilt
    - changed injector/coil wiring harness

    all this and it still runs like crap on the trailer its sluggish but will go WOT after it misses for a bit. on the water throttle response in sport and normal mode is very sluggish but it gets up to 35 and seems to run with no issues once its up to speed. I don't know what my fuel pressure is I think that's the next step in this issue. the only other thing I can think of that hasn't been changed is the fuel pump which I suppose could be delivering fuel but at a weak rate? or bad wiring to the fuel pump? if you guys have any ideas on a smoking gun that would be super helpful?

  2. #2
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    2,143
    +1
    436
    Try putting a can of Seafoam in the tank, could be water in fuel

  3. #3
    my ski has thrust vectoring......does yours??? killcraft's Avatar
    Join Date
    Jul 2009
    Location
    Moyock nc.
    Posts
    288
    Quote Originally Posted by moparguy View Post
    Try putting a can of Seafoam in the tank, could be water in fuel
    mill give that a try but Iíve sucked out the fuel and ran like three tanks through it at this point.


  4. #4

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    1,094
    +1
    72
    Bad map sensor will make the ski do all weird stuff..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 gti issues
    By killcraft in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-02-2020, 07:18 PM
  2. 04 gti RFI SE - still having issues
    By zoomjay in forum 2-Stroke Performance
    Replies: 7
    Last Post: 08-23-2019, 03:57 PM
  3. 96 GTI Issues (for a friend)
    By Blake Herling in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-26-2017, 03:11 AM
  4. 98 717 GTI carb issues
    By caliburn in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-27-2013, 12:54 PM
  5. 96 Seadoo GTI - take off issues
    By tthimlar in forum 2-Stroke Performance
    Replies: 7
    Last Post: 10-13-2008, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •