Results 1 to 6 of 6
  1. #1

    No Spark 97 hurricane

    Hi All,
    I got a real head scratcher here I have a 97 polaris hurricane with gen III ignition update. Ski has run good for a few years after me fixing it up when I got it and as of this year it died on me and seemed to have intermittent issues starting and now I get no spark at all. Things I have checked:
    - battery seems good 11.2v on red/purple while cranking
    - brown wire out of CDI 7v
    - disconnected black/yellow to rule out kill switch
    - stator seems to check out good
    Anyone have any ideas I'm at a loss here about ready to just call it a day and part the thing out.

    Thanks,

    Mitch

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    43,184
    +1
    2,258
    Cylinder compression?

    Intake reeds?

    Ignition base timing? Check that flywheel is at zero degrees when MAG piston is at TDC


  3. #3
    It runs fine if I can get spark. the problem is I'm not getting any spark.

    Compression tested about 125 in each cylinder
    Timing I have no idea but I've never touched it.

    Thanks,

    Mitch
    Quote Originally Posted by K447 View Post
    Cylinder compression?

    Intake reeds?

    Ignition base timing? Check that flywheel is at zero degrees when MAG piston is at TDC

  4. +1 by:


  5. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    3,503
    +1
    81
    The 7v on a connected brown wire is too low.
    Try connecting a 9v battery.

    K447 has a write-up to add 9v to save a CDI.

  6. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,230
    +1
    364
    I have found that with a no spark on the gen3 twin ignitions, it's normally the cdi.

  7. #6
    If you could link me to that, that would be great. looking at the prices online if this thing needs a new CDI I am probably going to call it quits based on the prices.

    Thanks,

    Mitch

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris hurricane 700 no spark
    By frostsnowman in forum Polaris Projects
    Replies: 1
    Last Post: 08-25-2016, 09:05 AM
  2. Replies: 9
    Last Post: 08-28-2009, 06:04 PM
  3. Polaris Hurricane NO SPARK
    By montecarloman90 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-23-2009, 10:48 PM
  4. 96 Hurricane-No Spark??
    By rustycg in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-12-2007, 01:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •