Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2020
    Location
    New Hampshire
    Posts
    14
    +1
    3

    Thumbs up 97 Gti 720 - Accelerator Pump an Upgrade or Not

    I have a 97 with the non accelerator pump single carb. It has a fresh engine 15hrs and rebuilt carb with a Makuni kit. Plugs look good. Iím still new to PWCs but the engine isnít neatly as snappy as the 600 carb Ski-Doo snowmobile I own. It also seems to be done having any more to give after 1/2 throttle. Would swapping to later 720 carb make it more snappy?

    My other PWC is a 99 Polaris SLTX that feels much more crisp, but itís a triple and like 35 more hp.

    Thanks for your advice in advance.


  2. #2

    Join Date
    Apr 2018
    Location
    Pearl River, LA
    Posts
    24
    +1
    3
    NOPE. Unless you got carb problems. Have you checked your compression, replaced the spark plugs?

  3. #3
    A ski will never feel as peppy as a sled. The sled has a transmission and traction.

  4. #4

    Join Date
    Aug 2020
    Location
    New Hampshire
    Posts
    14
    +1
    3
    New Plugs (Gapped), Replaced Coil, New Caps. Should the 720 still have lot to give after 1/2 throttle. Compression is 140.

    I understand it won't be as peppy as a sled but the motor doesn't seem to be as crisp under load either.

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,240
    +1
    367
    Yes, speed and rpm's steadily increase 'til it's pinned to the bars. Many times, people install a new engine without fixing the root cause of the first failure. Don't ride any more until the issue is resolved. Was the carb rebuilt when the motor was installed? Fuel lines replaced? Gas tank cleaned? Jet pump inspected?

  6. #6

    Join Date
    Aug 2020
    Location
    New Hampshire
    Posts
    14
    +1
    3
    The jet pump is the only thing not rebuilt. Everything else has been cleaned/rebuilt/or replaced. I checked the pump, changed the oil it was ok, but the slip ring was a little worn. Nothing major. It seems to quickly hit about 35mph by half throttle and then crawls by single digits after that.

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,240
    +1
    367
    Something is wrong. I would pull and go through carb carefully inspecting everything.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GPR\XLT Carb Upgrade\ Accelerator pump removal
    By OsideBill in forum Yamaha How To & FAQs
    Replies: 303
    Last Post: 07-13-2020, 09:43 AM
  2. Using stock intake on a 66v. Carb upgrade and accelerator pump disconnect.
    By Peteysparks in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 05-06-2020, 07:32 PM
  3. Replies: 2
    Last Post: 09-16-2018, 03:23 PM
  4. 720 accelerator pump issues
    By Rich1983 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 04-26-2015, 12:56 PM
  5. 2001 GTI 717 accelerator pump and carb question.
    By oneeyedjack in forum 2-Stroke Performance
    Replies: 4
    Last Post: 07-13-2008, 08:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •