Results 1 to 4 of 4
  1. #1
    synergyracing's Avatar
    Join Date
    Jan 2006
    Location
    Elkhart, IN
    Posts
    24

    Sea Doo 587 Help

    I have been beating my head against the wall with this 1995 SP which has been a nightmare. The synopsis of what is happens is as follows;
    I run the ski for 30-40 at 1/2 to 3/4 throttle, varying it around the lake. I start to loose a little RPM and then it drops 1500rpm. It begins to surge. If I take it down to a high idle for 10 mins, runs great for another 30 mins or so. I have replaced the following:
    spark plugs
    rebuilt the carb
    new fuel lines
    bypassed fuel selector
    new stator
    new coil
    new voltage regulator
    new battery
    clean fuel pickup

    I am a certified sea Doo mechanic and this is the first one in 20 years that has given me such a headache. I’m leaning towards an inner crank seal that when it gets hot, allows for my pulse line to loose “pressure” which in turn drops my fuel pump capacity. The engine is not seizing, compression is 150psi on each cyl. I’m at a loss.


  2. #2

    Join Date
    Apr 2018
    Location
    Pearl River, LA
    Posts
    24
    +1
    3
    Do you have an in line fuel filter on the system? I had issues with my 587 SPI (1996) and it was doing the same thing kinda. It would kill but had problems recoverning.

    Next.... Check the strainer at the bottom of the fuel baffle. I had one restrict fuel flow but only at high power. It would drain all the fuel from inside the baffle even thought the fuel tank was full. I found it strange the fuel gauge would read low. Good Luck !

  3. #3
    synergyracing's Avatar
    Join Date
    Jan 2006
    Location
    Elkhart, IN
    Posts
    24
    I have removed the inline filter and have my lines going straight from the carb to the tank. I also have cleaned the strainer but will pull it again to check it. Thanks for the response.

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,298
    +1
    377
    I had one this year giving symptoms similar to that. The new aftermarket coil was the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 07-06-2016, 11:37 AM
  2. WTB Wtb: Sea-Doo 587 engine
    By Liquid_Assets in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-06-2016, 08:00 PM
  3. 1995 Sea Doo GTS 587 engine compression
    By Stever in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-31-2015, 04:21 PM
  4. Replies: 4
    Last Post: 05-13-2014, 07:35 PM
  5. 93 sea.doo 587 sp
    By ssab in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-18-2010, 06:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •