Results 1 to 5 of 5
  1. #1

    Join Date
    Apr 2018
    Location
    Pearl River, LA
    Posts
    24
    +1
    3

    96 XP Surge at full throttle

    Pretty much done everything to the ski. It is fully restored.Runs 55mph on the GPS. Hit 57mph for a couple seconds one time. LOL At full throttle it pulls a little and backs off, pulls than backs off about once per second pull then a tad slower. Ski holds 55mph. I pulled the carbs (I rebuild them) to check for issues but found none. Pop-off is 37psi all Mikuni parts. I've done a number of these.

    I'm getting some oil dripping down the PTO Rave valve. I cleaned them a while back. I don't think this is a problem but... somethings up. Input help is appreciated.

    On a side note, this ski had weeks growing in the engine compartment when I got it so... I went through everything including repainting. All the gauges work, Trim works, new fuel lines, fuel valve, carbs rebuilt, jet pump... Water control valve... etc...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	XP 1996 9-25-19 Done (2).JPEG 
Views:	20 
Size:	197.6 KB 
ID:	467236   Click image for larger version. 

Name:	96 XP Paint James shop (3).JPEG 
Views:	25 
Size:	99.0 KB 
ID:	467237   Click image for larger version. 

Name:	1996 XP Painted 4-27-20 (8).JPEG 
Views:	29 
Size:	140.9 KB 
ID:	467238  


  2. #2
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    1,220
    +1
    124
    You might want to check your fuel pickup to make sure it's not cracked.

    Have you tried to run it on reserve to see if it makes a difference in performance?

    Use to have 2 95 XP's back in the day they were the bomb!

  3. #3
    Pacer's Avatar
    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    540
    +1
    97
    Did you install a new fuel selector valve or clean the old one? If you didn’t install a new one, then I bet that’s your problem. Don’t waste time trying to clean it better, just order an aftermarket one.

  4. #4

    Join Date
    Apr 2018
    Location
    Pearl River, LA
    Posts
    24
    +1
    3
    Quote Originally Posted by Pacer View Post
    Did you install a new fuel selector valve or clean the old one? If you didn’t install a new one, then I bet that’s your problem. Don’t waste time trying to clean it better, just order an aftermarket one.
    Yo dude !!! I live in Pearl River, LA. Son lives in Thibodaux !! I replaced the fuel valve. Shit is weird. I"ve been at war wit this ski, I gotta laugh about it cuz I learned a lot with this one. I have a little group on Facebook with about 140 members. Trying to get a nice helpful community in the area.

    I'm gonna look hard at the water control valve but I bet I did that already. Then again I might have the wrong size fitting on the exhaust system for the ski. I just went through that on a 1995 SPX. I didn't realize those fittings were sized for a specific ski and the water flow will affect performance. Still might be the carb. I might build another set just to have spares to swap out.

    Good ideas and sharing. This always helps others and I"ll certainly consider the advice and make sure it's up to snuff in those areas. Cheers everyone !!

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,232
    +1
    365
    Crack both high speed sdjusters open to 1/2 turn. If the prblem goes away then you know it's related to fuel delivery or the engine sucking a bit of air through a bad seal or gasket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 13 STX 15F surge hesitation above 50% throttle
    By JonCBrand in forum Kawasaki How To & FAQs
    Replies: 14
    Last Post: 09-13-2017, 04:09 PM
  2. Replies: 34
    Last Post: 05-13-2016, 06:43 AM
  3. '97 GTX.....idles fine, 1/2 throttle fine, full throttle......boggg
    By Flattracker60 in forum 2-Stroke Performance
    Replies: 9
    Last Post: 07-01-2014, 12:38 PM
  4. gpr1200 runs good till 3/4 throttle then loses rpms and speed at full throttle
    By zigp1212 in forum Yamaha PWC Performance (2-stroke)
    Replies: 34
    Last Post: 08-11-2013, 08:35 AM
  5. gp800r 'missing' at full throttle and when applying throttle
    By jim mcgreehan in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-24-2012, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •