Results 1 to 6 of 6
  1. #1

    Stx15 idle problems

    I have a 2013 stx15 it will shut off when riding randomly, sometimes 3 or 4 times a day or not at all. It also doesnít want to idle down at times and now when starting it when itís cold it wonít idle unless you blip the throttle and then it will idle. After it warms up that goes away. Thanks in advance for the help

  2. #2

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    1,185
    +1
    193
    It sounds like a bad idle air control motor to me. My '15 had the same symptoms but I know my mechanic had to make some other adjustments also.

  3. #3
    That’s what I was thinking it might be. Heard they had a lot of problems with them going bad.

  4. #4
    ANTONYUK's Avatar
    Join Date
    Oct 2007
    Location
    Russia, Vladivostok
    Posts
    313
    +1
    49
    Quote Originally Posted by Engineerfred View Post
    That’s what I was thinking it might be. Heard they had a lot of problems with them going bad.
    I have for sale
    http://foksmoto.ru/catalog/lodochnye...sikly/1419.htm

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    4,230
    +1
    364
    I have also had to put a new iac on an stx15 for thse same symptoms.

  6. #6
    dcuhpw's Avatar
    Join Date
    Jan 2019
    Location
    Guam
    Posts
    660
    +1
    47
    You can also just override the iacv and adjust for a fixed idle. That how I have one of the skis setup currently. Works great that way and hold a perfect 1200 rpm in the water. Sean’s tech post tells you how to do it


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 wave raider 760 idle problems
    By jlai in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-02-2013, 05:31 PM
  2. stx15 has slight high idle
    By slothman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 04-09-2013, 01:16 PM
  3. Idle problems with XLT1200
    By Kristina16 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 12-13-2011, 10:37 PM
  4. 96 BLaster II Idle problems
    By RxP Jumpin in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-22-2007, 01:39 PM
  5. Idle problems
    By O-ToWn1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-22-2006, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •