Results 1 to 5 of 5
  1. #1

    Sl 650 Drive shaft stuck

    Hey guys Iv been working on this old 1995 sl 650, the last think I have to do before getting it on the water is put the pump back on, however I canít get the drive shaft to slide in all the way, as you see in the picture thereís still a bit of the teeth exposed that should go it but it wonít budge. Iv tried grease Iv tried wd40, Iím not sure what else to do. The teeth are in good shape on both ends so idk why it will not go in all the way, any suggestions?


  2. #2
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	F7CC19B6-89BF-4C0D-93AA-907423274BE9.jpg 
Views:	38 
Size:	182.7 KB 
ID:	467103  

  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    43,369
    +1
    2,285
    Inspect inside the driveshaft coupler. Look for debris jammed inside. And check the splines for damage.

    There should be a driveshaft bumper on the end of the driveshaft. Make sure there is not another bumper leftover still inside the coupler. An inspection mirror or smartphone camera with flash should let you see inside the coupler.

    http://greenhulk.net/forums/showthre...=1#post3014226




  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,954
    +1
    74
    Your splines are not lined up.

    1. Chock your trailer or PWC cart wheels (or attach trailer to your truck) so it cannot move.

    2. Apply a lot of pressure to your jet pump (pushing it in) while you slowly spin the impeller.

    3. If that doesn't work, try barely spinning the impeller and try pushing the pump in. Barely spin the impeller and push the pump in, try it again, and again until it pops in.

    It takes a lot of force to get it to go, that's why you need to make sure the ski doesn't move when pushing.

  5. #5
    It was odd with mine. The first time I re-assembled it I had to give it a good boot to get it to fully seat. The next time I had it apart it just slipped right together.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Impeller stuck to drive shaft
    By 08 ultra in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 07-13-2020, 12:16 PM
  2. 2014 FX Cruiser HO - Impeller stuck to drive shaft?
    By lpgraff in forum Yamaha Projects & Build Threads
    Replies: 5
    Last Post: 07-31-2019, 06:30 PM
  3. 1200 tx drive shaft stuck! Please help!
    By Cpool in forum Polaris Open Discussion
    Replies: 24
    Last Post: 04-02-2015, 05:37 PM
  4. Help - 1200 GPR Drive Shaft Stuck
    By superd in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 12-26-2011, 03:04 PM
  5. jet pump stuck at drive shaft
    By bmc1818 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-26-2010, 07:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •