Results 1 to 5 of 5
  1. #1

    Join Date
    Apr 2020
    Location
    Maryland USA
    Posts
    2

    010 Ultra 260 X will not rev above 3000 RPM

    Please help. I have a new to me 010 Ultra 260X that will not rev up. It idles smoothly and runs smooth up to 2000 rpm. Then it starts to run rough and will not rev above 3000. The plugs are new, and are black/sooty, as if it is not getting enough air. I checked the air intake horn and it is in place and not blocked. The S/C belt is tight. I pulled off the BOV hose and started it, there is a lot of air being pushed by the S/C. I also placed my hand in front of the air horn and it sucked it in, so there is no problem with the air flow.
    There are no codes shown on the display, or I don’t know how to get them. I thought they presented themselves when trouble exists.
    I do have the service manual.
    At this point I suspect a sensor in the DFI system is bad. But wouldn’t that error cause the codes to show?
    All suggestions welcome. Thank you.

  2. #2
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    893
    +1
    25
    sounds like super charger has failed. your going to need a service manual


  3. #3

    Join Date
    Apr 2020
    Location
    Maryland USA
    Posts
    2
    Thanks Glenozzy.

    I thought my description of "I pulled off the BOV hose and started it, there is a lot of air being pushed by the S/C. I also placed my hand in front of the air horn and it sucked it in, so there is no problem with the air flow." essentially described that the S/C is working.
    Yes, I have a service manual. Although I did not see anywhere in it to tell me the boost pressure at x RPM for me to test/prove the S/C is functioning properly. Do you have that info or know where in the manual I can find it?


  4. #4

    Solution?

    Bumping an old thread here, did this get solved? I am having a similiar issue with my 09 kawasaki 260x. Revs fine out of the water and on the hose but as soon as it goes in it is limited to about 5000rpm and doesnt go beyond 50km/h. Boost guage was at about 10-11psi which seems normal. Changed to another set of spark plugs and no difference.

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    8,164
    +1
    845
    I don't know if the 260 had the upgraded jet pump or not. The 250 had problems with the impeller shaft moving and pushing against the crank and destroying the engine. Check for fore/aft movement of the crank. There are video on YouTube of how to do it.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 09 Ultra 260 wont rev past 7000 rpm
    By CayRider in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-22-2015, 12:37 PM
  2. Wave Raider won't rev past 3000 rpm
    By skeeter in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 06-15-2014, 09:40 AM
  3. 00 Yam. GP 1200r Wont rev Past 3000 rpm.
    By Rob Stretch in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 04-29-2014, 08:15 PM
  4. ski wont rev above 3000 rpm on r12x
    By thegasman34 in forum Honda How To & FAQs
    Replies: 5
    Last Post: 08-16-2010, 06:25 PM
  5. WaveRaider won't rev past 3000 RPM ?
    By Jolly Roger in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-20-2008, 02:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •