Results 1 to 5 of 5
  1. #1

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    1,039
    +1
    166

    Water Hose Replacement...

    Hello all,

    I fell victim to the well known crappy hoses Kawasaki put into my 2012 300x with one splitting at the fore oil cooler hose connections. I got some Gates hose in the same size that rated for 400Psi and nylon reinforced. I was wondering if that should be enough to hold it this time? I am assuming that 400psi is way less than the pump produces but I wanted to check and see what you guys thought. Thanks..

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,836
    +1
    785
    400 is significantly more than the pump produces. You'll be fine.

  3. +1 by:


  4. #3

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    1,039
    +1
    166
    Quote Originally Posted by steve45 View Post
    400 is significantly more than the pump produces. You'll be fine.
    Thank you sir. Kinda figured but wanted to ask. Hopefully this hose holds up better than the OEM stuff. Thankfully I had a bilge pump installed.

  5. #4
    If you’ve had 1 let go, might be time to do the rest. I had one which was leaking for some time on my 2013ultra 300x, couldn’t for the life of me find where the leak was coming from, so changed every water hose. Glad I did because I found 3 hoses that had delaminated about to burst. I used the same hose you did. Industrial style 400psi rated hose with new clamps

  6. +1 by:


  7. #5

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    1,039
    +1
    166
    I ended up putting all new Gates hose in. Pulled the intake off, cleaned the injectors as well while there. Everything is back up and running now. Thanks for the advice guys..


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in bilge area... found hose leaking. What is hose and where to order? Pic attac
    By Waverunner4Me in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 10-19-2019, 11:13 PM
  2. Hose replacement
    By enforcer in forum Flyboard
    Replies: 0
    Last Post: 07-21-2017, 08:51 AM
  3. clogged hose? garden hose connected and no water coming out
    By 5string in forum Honda How To & FAQs
    Replies: 1
    Last Post: 10-16-2016, 07:31 PM
  4. Replies: 2
    Last Post: 09-21-2013, 10:28 AM
  5. Replies: 0
    Last Post: 07-29-2011, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •