Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25
  1. #21
    Quote Originally Posted by BLASTER 1 View Post
    Was this issue ever solved?
    What was causing the problem
    No, not yet . Replace the ribbon with a ribbon delete kit from riva still the same . Also remove head cover to check timing and it’s still on point so I am completely baffled right now on what it could be


  2. #22
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    3,074
    +1
    139
    Might want to check fuel pressure since you have all the other 2 compression and spark, the regulator might be dumping too much fuel or not enough. You can probably get one pretty easily since they are removed and its spot is plugged when we switch over to to a RRFPR.

  3. #23
    Saum700p's Avatar
    Join Date
    Sep 2017
    Location
    New Orleans
    Posts
    494
    +1
    80
    Quote Originally Posted by ultramaxracing05 View Post
    Might want to check fuel pressure since you have all the other 2 compression and spark, the regulator might be dumping too much fuel or not enough. You can probably get one pretty easily since they are removed and its spot is plugged when we switch over to to a RRFPR.
    I was told there is an issue with the accuracy of the riva fuel pressure regulator gauges... Ive seen sparatic numbers on mine.. Just another thing to check

  4. #24
    I'm starting to think that maybe the flywheel may have shifted . (hope not!)
    anyone else experience this?

  5. #25
    Saum700p's Avatar
    Join Date
    Sep 2017
    Location
    New Orleans
    Posts
    494
    +1
    80
    Quote Originally Posted by waterfreak View Post
    I'm starting to think that maybe the flywheel may have shifted . (hope not!)
    anyone else experience this?
    I had that happen on my vxr. I doubt thats your problem because when mine did that it wouldn't start at all. check the wires on the back of your injector plugs. see if any pull out easily. They should be locked in. I had one break out of the blue while I was riding a few weeks ago.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2018 GP 1800 for sale.
    By fxnytroxtx in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 09-15-2018, 04:03 AM
  2. gp 1800 or new 2018 RXT???
    By tusk in forum Yamaha PWC Performance (4-stroke)
    Replies: 46
    Last Post: 12-27-2017, 09:45 AM
  3. gp 1800 or new 2018 RXT???
    By tusk in forum 4-Tec Performance
    Replies: 14
    Last Post: 12-12-2017, 08:09 PM
  4. 2001 polaris virage txi stalling/starting problem
    By 2000 gtx rfi in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-01-2011, 09:36 PM
  5. Stalling and Hard Starting
    By Center87 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 03-24-2009, 06:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •