Results 1 to 6 of 6
  1. #1
    HottubMark's Avatar
    Join Date
    Aug 2020
    Location
    Oronoco,Mn.
    Posts
    16
    +1
    1

    Help !!! 2002 Polaris Genesis

    Ok,,Here we go,,2002 Polaris Genesis i,,Bought this 1 week ago,,Prior owner ran it All last season without a hiccup..

    Stored it for the winter,then pulled it out and would Not start,,after a friend started looking at things,,he found that the oil injection cable was broke,,he decided to put alittle starting fluid to it and it took right off for about 4 secs.. they did this 4 times over the next acouple of weeks ,,with same results.. He took it to a shop ,,and they said it was probably fuel issue ,,without even really doing any kind of tests on it. Charged him 250.00 and he left. He said no more and went and bought a New ski..

    I saw the listing on it and went up to see it,,Friend was selling for the owner,,He did the starting fluid thing,,BUT this time it kept running ,idled fine and even revved up fine..But would Not re-start on it's own without a shot of juice.. I still decided to buy it.

    Got it home and went for the fuel pump area to check the regulator thing that has been described on here,,all is intack and good pressure. Today i thought a replacement fuel unit would arrive ,,but it didnt..i decided to put 3 New plugs in it and put the pump back in,,(after draining gas and wiping the tank clean..)

    The ski would not even fire abit,,took air cleaner top off,,shot alittle starting fluid and away she went,,idled fine ,,but has alittle miss to it when giving some throttle,,which it didnt have with the old plugs..

    I hope the different pump assembly comes tomorrow to try that,,,but any help i can get at this point would be GREAT !!! Thanks

    Side note,,I have no idea if the owner knew the oil injection cable was broke,,my prior understanding is that if the cable breaks,,the pump feeds full oil supply to motor,,so it doesnt seize ,,but will foul it out,,Is this true with this ski?? and could i just have way too much oil in the crankcase at this point?? I need help here,,I really dont want to part it out!!!

    It is Very hard for me to believe that a part went bad sitting in storage,,i just need to find the starting issue!!!
    Last edited by HottubMark; 09-12-2020 at 06:57 AM.


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    43,535
    +1
    2,321
    Starting fluid is hard on these engines.

    If the engine will not start by itself without a fuel prime that is often an indication that the EMM needs repair.

    Continuing to start and run the engine using fuel prime (or starter fluid) can cause further internal damage to the EMM.

    http://polarispwcknowledge.shorturl....t-things-to-do

    http://www.greenhulk.net/forums/show...=1#post2917494

  3. #3
    HottubMark's Avatar
    Join Date
    Aug 2020
    Location
    Oronoco,Mn.
    Posts
    16
    +1
    1
    Thanks the info,,I guess that the EMM went bad from being stored ,,mostly when it ran Great all summer long..I sure hope spending the 500.00 to send it in is refundable if they find nothing wrong with it..

  4. #4
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    3,218
    +1
    275
    EMM testing is offered for a nominal fee, so no concerns about committing to a full repair.

    Stator testing is a desirable next step.

  5. #5
    HottubMark's Avatar
    Join Date
    Aug 2020
    Location
    Oronoco,Mn.
    Posts
    16
    +1
    1
    Quote Originally Posted by HiPeRcO View Post
    EMM testing is offered for a nominal fee, so no concerns about committing to a full repair.

    Stator testing is a desirable next step.
    Thanks Much for the info and the e-mail and the link to checking the stator,,this really gets me started on checking things!!!!!

    Thanks K447 for the Great write-up on testing the stator!!!!!

  6. #6
    WKUalum's Avatar
    Join Date
    Oct 2020
    Location
    Fenton MI
    Posts
    29
    Curious what the end result was with your machine.

    Quote Originally Posted by HottubMark View Post
    Thanks Much for the info and the e-mail and the link to checking the stator,,this really gets me started on checking things!!!!!

    Thanks K447 for the Great write-up on testing the stator!!!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help with 2002 polaris genesis i
    By beau1988 in forum Polaris Open Discussion
    Replies: 13
    Last Post: 02-17-2020, 07:40 AM
  2. 2002 Polaris Genesis I
    By Jross1127 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-02-2016, 01:53 PM
  3. 2002 Polaris Virage TXi and 1999 Polaris Genesis 1200 Help!
    By Big Willy in forum Polaris Open Discussion
    Replies: 22
    Last Post: 01-23-2016, 11:31 AM
  4. FS - Parts Polaris Ficht throttle body rack from pre-2002 Genesis I or Genesis FFI
    By K447 in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-26-2015, 01:07 PM
  5. FS Polaris 2002 Genesis & Genesis I seats
    By zrtman in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-02-2011, 07:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •